So my extruder was clogged and I used the unclog tool and now the extruder is clicking and not extruding or grabbing the filament when i try to load the filament back in I gather this means my extruder is busted? Or is it clogged?

Check the connection on the stepper motor. One or more of the 4 wires may not be making a proper connection. I had a similar issue. The yellow wire had completely pulled out of the plastic connector.

is the nozzle hot?

By no means an expert. Try going to unload. And manually push PLA through (you might have to pull it out a bit first) when it finally starts flowing is it straight and smooth or all bunched up at the nozzel. If it is running smoothly perhaps (as mentioned below) the issue is with the drive. You can remove it using the screws on the front fan, check that the grooved drive mechanism isn’t filled with plastic. Last ditch effort would be to contact support (I hear they are pretty good) or try YouTube and look for help with a flashforge creator as they are very similar. If you find out what is wrong post back to let us all know. I find that available support for this unit online is still limited.

I’m going to call support as soon as they open to see if they can help me figure out the issue this printer has been amazing so far I just hope I didn’t screw it up


Hi there. I had this exact same thing happen to me this weekend but the good news is that there is a solution! When you used the unclog tool, you probably “mashed” the filament into the inside of the extruder hole, which then burned solid, and no amount of pushing will force that clog through. First - take a few detailed photos of the top of your extruder so you are familar with the connections and wiring placement. Then follow the steps in the attached PDF to take apart the extruder (this was sent to me by Dremel support). Once you’ve unscrewed the fan and moved it out of the way, first check for any filament in the gears themselves. Then lift the whole unit off of the extruder head and you’ll probably see some filament mashed into the hole. Just take a needlenose pliers and pull it out from the “top” (not through the bottom). If you can’t do that, then trim as much of that “mashed” filament from the top as possible, re-assemble the extruder (be sure that all connectors are fully set), run the “Load Filament” step, and feed new filament into the unit (be sure the end of the new filament is flat).
Extruder drive gear unclog service document.pdf (841 KB)

1 Like

I have used dremel a lot so if you want to post a picture I will be able to help you more. But you can contact their support to get a new one.

Open the extruder after they give you instructions.

I took off the fan like they said and there was no loose filament at all in the gears so I figure theres pla jammed in the nozzle so then they sent me deep clean instructions which i did but it didnt change anything but I could feel pla inside the nozzle and was only able to get miniscule amounts out I called again and they told me to heat the extruder up with the front fan off for an extended period of time so thats what im doing now

im kind of confused by where you mean the filament got jammed into

And here is what the gear box of the extruder looks like

as of right now after heading the extruder for about 50 mins the clicking has stopped when i try to load filament but the nozzle is not extruding

Hi Zipperboy… I am sorry to hear you are having this trouble. Please call us at 1-844-437-6533 for help. Dremel 3D Customer Service

Problem is fixed after a couple hours of messing with the extruder thanks everyone!

Hello Zipperboy. I had the very problem with my printer. What the problem is that some of the filament that is in the nozzle is not getting in contact with the heating element, so that is one of the reasons the extruder is making the clicking noise. It still has some unmelted filament that is blocking the nozzle. The only way to fix this is to take apart the extruder so that you can get in contact with the nozzle. I did the same thing, and fixed it and it is as good as new. Hope that helps.

Can you post a brief description how you did this.

You will need an allen wrench to unscrew the fan that runs parallel with the x axis. Once that is removed, remove the block to reveal the inner workings of the nozzle. You should be able to remove whatever is in there.

most likely there is filament wrapped around the gear pulling filament into your extruder. There are some Allen bolts on the front (facing you) of the extruder you can loosen while the power is off, and it cools. These long Allen bolts hold a fan and a heat sink into the extruder and removing them exposes the gear. Simply remove the bolts, the fan, the heat sink, and check the toothed gear and you will likely see the problem. Cut the filament where necessary and gently remove it, then reassemble. Allow the extruder to heat up and go through the loading filament process and you should be good. In my experience this is caused by putting too much pressure on the extruder nozzle during leveling. Happy printing :slight_smile:

Thank you for sharing the PDF.
“If you can’t do that, then trim as much of that “mashed” filament from the top as possible, re-assemble the extruder (be sure that all connectors are fully set), run the “Load Filament” step, and feed new filament into the unit (be sure the end of the new filament is flat)”

I made an account just to say, thank you so much for that piece of advice.
I took apart my first 3D printer (with help from the PDF you so kindly shared), and managed to successfully unclog my first clogged extruder incident after trying different things before I tried what you said. ( Words cannot describe how I felt seeing filament finally extruding at 1:30 in the morning T_T I even took a photo to commemorate this moment.) I now feel like I know what to do the next time this happens. So thank you, you kind person you.