Hi really hoping someone can help. My Zprinter 450 no longer boots, when i turn on the machine it beeps 3 times pauses and repeats. There is also no text on the LCD just a blank white box. If anyone knows what the beeps mean or if there is anyway of running a system check that would be greatly appreciated.



3 beeps generally indicates a RAM error on the motherboard.

I would also inspect the board and power supply for swollen or leaking capacitors.

If you have not done so already, making a backup of the hard drive is a very good idea.

Good luck and let me know if you need general guidance.

1 Like


You would have to reset the motherboard.

You would need to plug a vega monitor and keyboard.

Reboot the printer and the setting will load on the monitor.

Email me and I will send you the doc to reset the mother board.

If that does not fix the issue then your motherboard overheated and damaged the CPU.

There is a fan on the cpu make sure it still works.

Over time that fan will give out. We had this issue before.

1 Like

Hi, Thank you both for the reply. I’ve now fixed the problem it was a dead stick of Ram. I’m now back to the original issue i was facing before i posted on here. I keep getting HP11 continuity check failed error code 40800, I’ve already thoroughly cleaned pinheads, pogo pins and connectors. Tried multiple new pinheads, bought a new pogo card and carriage ribbon cable but to no avail. I’ve manually checked most of the cables on the machine for continuity but everything seems fine.

Have you tried new pogo card?

Hello, May I ask you the documentation that you were proposing to Aaran to reset the motherboard? I bought recently a Zprinter450. I had recently to change the battery of the motherboard. Since then once the printer is online, as soon as I connect it to a router to put it on the network, the printer hangs up and does not react anymore. May be that the motherboard needs to be reset. I would really be happy if you could share this documentation. Today I am pretty much stuck and I did not have yet the chance to print any single part. Kind regards Mourad from Switzerland

I have a MiiCraft 125 3D printer. it worked just fine until 2 weeks back. after I switched it off and tried switching it on the next day, it won’t boot past the power on that flashes across the screen. Need help. could it be a motherboard issue? also how do I fix it?

the solution that you proposed will it work for my printer too?

or could you help me with mine?

hi! I have almost the exact same problem… I replaced the CMOS battery and pogo card. Hardware seems to work as long as i dont connect LAN. Have attached vga,keyboard to the 450, everything is locking up when i connect LAN. I am suspecting wrong bios settings. Are you able to send me the correct settings? Best regards, Jon Christian

Hi Christian, As you say, i had the same problem as you. I can tell the end if the story. Actually i tried many things unsuccessfully. I finally asked a 3d system representative to have a look. Bios was fine. He tried to fix the problem unsuccessfully as well. He recommanded me to buy a new motherboard, which i did. Once installed, the printer works fine since then…

Hey so I’ve bought a zcorp 450 printer and it may need a new mother board due to the heat sink falling off and frying the board. On a post on here it says you bought a new mothe board for yours. Can I ask how much you paid for it and where you bought it from?

Hello i have the same pb with my zprinter 450 so can you send me by mail on bats33@gmail.com the doc to reset the mother board please ?


If anyone here has these docs, can you please send it to me aswell? Aambakk@gmail.com