We recently picked up a Zcorp 310 and I am having problems connecting to it with ZPrint. I’ve tried plugging a monitor into it to see what it does when you turn it on. It powers on and then starts the ZCorp software just fine. The IP address that it shows has nothing to do with our network. Is there a way to change its IP address? Any Help would be greatly appreciated.

1 Like

Did you get your answer. If not I can help you.


i have got the same problem. The ZPrint Software also sais there is no printer with this IP adress…

Did you get the printer working jet?


I can help you but need a few answers.

How are you connecting to the network port. Have you set the IP address or is it set to default. Was it used and it has their network info in it still. Have you set the printer up to connect to your network. Is this a home network or a business network.

I have attached the Ethernet setup instructions if you do not have them.
ethernet_connection_setup.pdf (301 KB)


thank you very much for your fast answer. in the meanwhile i was just in the traffic and so on…

I run a small sculpting studio for art and movie props. I would like to try the Z310 (may be “plus”) instead of my older Cube printers. It is a used one. The materials and the working principle seems really better for me.

There is no network at the studio - only a router at my neighbours place.

I put a switch between the cable from the router and my HP Z800 workstation.

From the switch i connected the Computer and the printer. Internet works again perfektly for my computer

With a small VGA screen i watched the Z310 firmware starting and wrote down the IP Adress:

Also a MAC Adress is shown.

When i run Zprint 7.10.3 or 7.6 it says there is no printer on the network. But i see a “Zdns reply to IP of my Workstation” popping up in the firmware screen. Also a network test software find the IP of the printer, but a ping does fail.

Thank you for the network settings guide. I didnt do very much wrong i think.

But i do not understand the settings in Windows or the possibility to setup the network in the printer itself.

When i connect a keyboard to the printer it is recognized at booting but looks like getting ignored from the running firmware.

I am really new to network printers and tried to setup somthin in windows10 to connect the printer but there was no printer or other machine found. With manually settings for a network printer i get always shown a screen for inkjet printer settings, not for a"neutral" network machine.

I just ordered a (two female) serial cabl hoping it connect with this…i really would be happy about a working printer



Need to know what the network address of your machine is. If you connected your switch to a router than I would assume you are set to get your IP by DHCP. I need to know what your IP and Subnet is set to on your windows 10 Machine. If you are unsure how to do this, I think the easiest way is to open a Command Prompt (Windows Key + R then type cmd and hit enter) then type in ipconfig and hit enter. What I need to basically know is if the Z800 is in the same network address space as your Z310. It can be plugged into the same switch but if the Z310 is set for a static address outside of your router address, the computer will not see it. I do not think you will need the serial cables. This should be an easy fix. An easy test would be to change your Z800 to a static ip address of If the subnet is default than you should see the printer but would loss internet. But this would confirm only printer is fully functional.


this looks like the right way to me. When use the router as a switch and try to find the printer, it says the printer adress is in the “wrong space”.

What a pitty, i am all day working outside at another workshop. I hope to get there in the evening to empty the car, and then i can take a look.

Thank you very much…

Hi there, this solved my problem perfectly. Thank you very much! I also Manager jet to write a nee .ini to change the printer IP into my “network”. Do you know the printhead overheating 1006(0) problem?

need a new print head