Hi, can anyone help me figure out why the top of the model seems to be missing a few layers? There is nothing wrong with the file itself.

You can see my shell thickness and other settings in the attached image from Cura.

Thank you in advance!

It can be 3 things, not enough top solid layers, infill percentage being too low or simply under-extrusion, I could be more exact if you told me what was happenin during the print. Hope it helps.

From the looks of it, no layers are missing. This kind of printing issue is know as “pillowing”. Pillowing ranges from little “bubbles” all the way to “blow-outs”. In your case, it is blow outs. It happens more with ABS than PLA because of the gas emission, high temp, and not being able to use fan. TomaszL just gave the possible remedies to your issue.

Pillowing happens from hot air that gets trapped in the infill gaps. So, if the infill gap is too big, the covering filament will be stretched out. Yet the hot gas from bellow will try to push out. Even after adding couple of layers, the same issue may persist. I have seen it happen with 6 layers of 100 micron solid layers. For me, at 200 micron layer height with 30% infill, never went bad - even with only 2 top solid layers. I even used ‘fan’ on ABS for the first top solid layer (you can do this with add-on for Cura).

This is a very common issue with Cura. For some reason, it’s 25% infill and bellow creates very big gaps. Just at 26% and above it changes dramatically. That’s why I never slice with Cura at less than 26%.

Hope this helps you in understanding your printing problem.

Hi, thank you very much TomaszL and hamakis3D.

I set the Fill Density to 40% for this print though.

I am seeing these horizontal uneven layers, even at 0.1mm layer height though. I’m not sure if this has anything to do with the pillowing issue.

I think that playing around with the flow rate might solve your problem.

I have now increased the Fill Density to 50% and the Bottom/Top thickness is set to 2x (2.4mm) the shell thickness (1.2mm). It still looks about the same.

The Flow % is 100.

Nozzle size is 0.4mm and the filament is 1.75mm.

This is driving me crazy - it still looks like a few layers are missing from the top of the part. The part was designed by a 3D print design house, and they assure me that the design is not missing any layers.

Try setting the flow rate to 110% and if it doesn’t help, you can set it even higher. I have a question, does this occur with every print?

I will try 110%, thanks.

I will try printing another model as well. I did a very small thin “donut” of ABS (2-3mm thick) and it printed fine.

Do you think it’s related to the extruder falling down when the print is finished or the power to the printer is off? Perhaps the belts need to be tightened? Could this be leading to what looks like missing layers throughout the part?

What firmware are you using? and could you give me a link to it? I will look into it because im pretty sure there is an option(atleast in marlin) to prevent the Z rods from moving backwards each layer, this is caused by the motors being turned off after they move the carriage up.

Firmware is 2.1


However, I’ve always had this firmware and the extruder falling is a new phenomenon. It never did this until a few days ago…

Sorry, where is the extrusion distance setting?

the line in the firmware is #define Disable_Z it must be set to false. Another thing to try is reducing the extrusion distance to 1.5mm(lower flow rate)

The extrusion distance is set by the flow rate, depending on the printer you own, you will need to adjust the flow rate accordingly. If you dont exactly know how to do it to exact values than you can just test different flow rates and try to find the perfect one. Your problem might be caused by both, under and over extrussion so I would play around with lower and higher values of the flow rates. Take a few days to test some flow rates as this will most likely solve your issue. Im sorry for the misleading instructions :slight_smile:

Your layers look like crap. Have you calibrated the heat for this material? Have you tried a different filament? Have you tried printing slower? The gaps in your layer could be caused by clogs(which could be anything from bad filament to wrong extrusion temp) or the extruder slipping(not enough tension).

As for the top of your print, you need to increase the perimeters(shell width). As the angle gets steep your perimeters are printing onto infill. Slic3r offers many more options and more control over the slicing, which really helps in getting stuff like this to come out correctly.

Thank you very much TomaszL!

I experimented with Flow of 100%, 105%, 110%, and 115%. If anything, that made the holes in the top layer slightly worse.

So now I will experiment with <100% flow.

Messing with the flow rate is NOT the way to solve your problem. If your extruder is calibrated(is it?) you should never mess with the extrusion rate because it throws off all the calculations of your slicer. You might improve one area of the print by extruding a bunch of extra material but this will throw off the rest of the print. It doesn’t solve your problem.


Changing the flow rate wont mess up too much on the quality side, a better way of changing the extrusion rate would be to change the steps per millimeter for the extruder stepper motor in the firmware.

Is your problem solved?

Hi, I am cleaned the extruder’s gear wheel, as suggested by WASP. Did not seem like there was any debris, but I put a toothbrush on it, and the silver adjacent wheels that feed the filament.

When manually feeding the PLA, I noticed that it didn’t extrude well until I raised the temp to 210C (I was at 200, 195, and 190 before). Now at 210 and 100% flow rate the part looks perfect!!

Could it just have been the temp set too low?