I recently acquired a z510 and have finally gotten it all cleaned up and unclogged.

I’ve done a few prints with it but more often than not, when I tell zprint to print, windows stops the program and tells me there is a problem.

I’m running zprint 7.10 that I downloaded. I’m not sure if it’s a problem with the program or another problem.

I have tried it on various machines with similar results. I’ve tried it on Windows 10 & XP

on actual machines and in virtualization.

Has anyone experienced this? Does anyone know where I could get another copy of the zprint software to try?


3D systems has the software on their site. I am using 7.10 on a windrows 7 and xp machine. Try dl the software from 3D systems and try to reinstall

Thanks. I found it on their site. I had to search for it. It isn’t listed there anymore.

i think the problem was related to trying to use custom powders. I think it’s crashing when I try to set the saturation to high.

Move had a few successful prints in the last couple days.

Running on xp though. I think I’ll try to switch back to a modern OS next.


It will defiantly crash if you have edited the build recipe incorrectly. Try to make sure that is deeres and then reinstall. That has happened to me when I was trying to get tricky.

I wasn’t even editing the recipes directly, I was just deriving a powder from a stock one and increasing the binder percentage.

I turns out I didn’t need to, hydroperm is printing well at pretty normal saturation levels.


Hi Charles, I have zPrint 7.10.3 install files if you need it, I can sendt it to you. We have used this version thru the whole progress from XP - to 7 and now Win10.

I bougth a Z-510 Spectrum new in 2006, but its been parked the last year. Mostly print plugs and molds with it, and when I now started it up to print some sand moulds it failes booting.

My problem occurred to be an error coming up at booting saying comm error on headcard, flags = 1f , but in the boot sequence it stops and says 0601 Diskette Error . (I have hooked up av vga screen and a keyboard to the machine)

After buying and installing a complete new headcard from 3DS, it still stops with the same error.

Thing is, I think the “hard drive” could be damaged, or the boot file corrupted. The hard drive on this machines are a 40 pin IDE flash of massively 32MB :slight_smile:

I can not find any of my former contacts from z-corp, and a reply from 3DS about a fresh boot file or a new IDE flash with boot config have not shown up.

I have now ordered in an “of the shelf” 40 pin IDE 32MB flash unit, and was hoping that some one could be willing to copy the file from their 40pin IDE flash on a working machine, and share the file with me…



thanks for the offer. I found the software on the 3ds website.

I would be happy to image the drive and send the file to you. I have been meaning to make a backup of it anyway.

I should be able to do it tomorrow.

You can email me at jeremy@charlesrivermaker.com

I would love to get a copy too if possible. I can give you my ftp info so we can share with other 510 users. It would be great to keep in contact with you both. It’s great to meet other 510 users. I would love to share info, material recipes etc and finishing processes that work well.


Cheers Charles ! Splendid

Things have been busy, but when I have a mirror of your flash disc I will use time to get the 510 up to speed again :slight_smile:

Sent you an email for the file transfer.


It’s great to have some other 510 users to talk to. I might have to set up a new Wiki with recipe info. I’m having good success with homemade binder right now and hydroperm and am hoping to try a few new powder recipes.

I’ll try to image the boot drive today.

That would be great. I just purchased some hydroperm and hydrostone. Would love to hear what is working. I also purchased melodextrin and some other things. I didn’t find a good source for pva powder as an option to try. What binder are you using?

The binder I’m currently using is this:

Minus the potassium sulfate & proxel gxl as I didn’t have those ingredients at the time.

Distilled Water: 93.45% volume (3537 ml)’
**‘**Surfynol 465: 0.5% volume (18.92 ml)’
**‘**Glycerol: 6% volume (227.12 ml)’
**‘**Potassium Sulfate: 0.2% weight (7.5 mg)’
**'**Proxel GXL: 0.05% volume (1.89 ml)

It seems like the potassium sulfate is there as an accelerant for the plaster. The proxel GXL is an antimicrobial.

I purchased the surfynol (2,4,7,9-TETRAMETHYL-5-DECYNE-4,7-DIOL ET) from Sigma-Aldrich.

I have some dry clay on the way and I have some maltodextrin and PVA powder. I think my first attempt will be with sugar instead of PVA though as it’s cheaper and it only needs to hold together until it’s fired.

I got replacement printheads from here: https://www.discountinkllc.com/products/hp-11-black-print-head?variant=9816827653

They aren’t genuine HP heads but they seem to be working fine for now and they are certainly cheaper.

I’ve also been playing with trying to revive the heads that came in the machine but cleaning them in an ultrasonic cleaner and flushing some binder through them with a kit from ink owl (Printhead Repair Tool for HP 10, 11, 12, 84, 85 - InkOwl)

I didn’t think it would be such a pain to image this drive, I don’t have much equipment around anymore for IDE drives.

The one computer I could plug it in to isn’t recognizing it correctly once it boots to linux.

I think I’ll try to grab an IDE->SATA adapter tonight to give a try.

Was the surfynol a pain to order? I just tried to register but they want an existing sigma… Act.

It wasn’t too difficult. I think I just had to set up a new account and give them my EIN. So, if you don’t have an EIN, they might not be too helpful. They also warned me that they wouldn’t be able to ship hazardous materials to my home address, luckily, the surfactant wasn’t hazardous.

I did also run a water/alcohol binder with a tiny bit of dishwashing soap in it, it seemed to work ok but I think the straight water binder works better with the hydroperm.

Hey Jan

to to get rid of the diskette error you need to boot to the bios setup. I think it’s the delete key. It should say it on the screen during boot. Then to disable go to the boot options and go down to floppy drive and disable it. Then it won’t check for it any more and should boot past that.

So I think I found a source for pva thats a bit cheaper… they want to have me order about 88 pounds cost is just under 10 delivered. It is 1788 grade and about 300 mesh they said


I finally found some people talking about the Z510.

Anyhoo, sorry to send this off on a bit of a tangent but as there’s already a captive audience of 510 users. :slight_smile:

I’m trying to revive our school’s Z510 and have hit a stumbling block. It boots, and seems ok, I can send a job to it but then it randomly throws an overheat error on either head 2 or 3.

I’ve replaced the heads for both of these but no luck.

Not sure if there’s anything else I can do and there is zero budget for repairs (like I said, school, we got the thing when our budget was flush a few years ago but even then they bought it 2nd hand).

So any ideas, hacks, etc? I’d really like to get this going again.

A few things to try and figure out the source of the problem… Old or contaminated binder can be a source of overheating heads. Flush the lines and leave bleached water in them overnight. Make sure the filters are clean and you can pull fluid easily through the lines. If it’s hard to pull that can cause heads to go out also.

Clean the shiz out of the pogo pins with alcohol and make sure the ribbon cable is seated well. Are you using oem heads or knockoff?

My machine had lots of dried up binder in the lines. I pulled a lot of clean distilled water through until it ran mostly clear. I also ended up blowing the lines out with compressed air at the connector inside the printer. There was a lot of gunk.