I have ran in to a problem which I could not solve by myself. The printer I own is a Flashforge Pro printer with dual extrudes. It is only a few months old and have only printed a handful prints. However those few prints are 40+ hours each.

I am new to the 3D printing world and have run in to a problem I could not find a solution on google.

I have recorded my problem. Warning, it is kind loud.


It all started with my prints started to shift mid print, like the leaning tower in Pisa. So after 13 hours in to a 29 hour print i stopped the print because it was way to crocked and was on its way of the print bed. So to investigate my problem I loaded up a new print. This time a small chips clip that would only take one hour to print so I could sit and keep an watchful eye on the print.

As soon as it was heated up and started printing it started moving more and more to the left… I saw it… it was every layer instead of every 20-30 layers. The entire print head was shaking and seamed like skipping on the bands that pull it back and forth. I first thought my print nozzle was dragging on the bed so I tried level my bed… That’s is when it just stood still in the middle shaking and jumping and making all kinds of noise. I stopped the leveling program and removed the entire block and tried to level the bed again. Still the same. (Like in the video)

I tried cleaning the bands and looking for missing teeth’s but could not find any problems.

I searched the web of Internets and could not find an answer to what could be wrong so I am now asking for advice on how I can proceed.

Thanks in advance.

Since the problem is coming for the x axis motor there is 90% chance that the cable to the x axis motor coming from the driver board is faulty or the driver board itself is faulty. I have faced the similar issue and in my case the driver board for x axis was faulty.

To fix this first remove and exchange the x and y axis driver boards by getting access to the motherboard. If the same problem now replicates on the y axis motor, you have a faulty driver board which is now on the y axis (originally on x axis). If the problem is still with the x axis even after exchanging then the x motor cable is faulty. Either way the problem will be among these 2 things only.

Check once and try the steps i told above. Let me know if you have any doubts.

I was able to fix the problem after a lot of trial and errors… The problem was a faulty cable from the X-axis motor and the motherboard. After replacing that cable it worked perfect once again…

Thanks lakshaywadhwa17 for the advice to where to look…

The problem is now resolved.