Hello, I ordered an e3d titan extruder, Pt100 thermistor and an e3d v6 hotend for my anet a8 printer flashed with marlin.

I have been trying to install these parts for my printer on and off for 2 weeks and there are several problems that I’m having trouble fixing.

  1. I tried to test out the extruder to see if the gears had moved. The motor which came with it didn’t have connectors
    with it but wires coming out of it. The wires were short so I soldered them to longer wires.
    At the end of the wires, I had crimped the wires with a DuPont female connector and put a 4 pin on it.
    when i turned the printer on and tried to move the e axis, the gears didn’t move.

  2. As for the hotend. My issue has been with the Pt 100. I had installed it to the hotend, wired it up to the amplifier,
    and wired it to the mainboard by making a custom DuPont 3 pin female wire. When i Tried testing it gave me weird outlandish temperatures
    when i tried to preheat the hotend, it would stay the same temperature for 20 seconds and give me an error saying “E1 Heating failed.”
    I have a feeling it either might be because of my wiring, marlin configuration or the heater cartridge.

I have pictures that show all the wiring that i had to do and what i had changed on marlin. As for the Pt100, i had changed it to the stock thermistor that came with the V6 and i still had the same problem, Just with a different temperature reading.

Any help would be dearly appreciated. Thanks.

Firstly, be aware that you may have a safety feature enabled in your Marlin firmware that prevents the e motor from going if the hot end is not above a certain temperature. Try heating up your hot end to 170 degrees c or above and try the extruder motor again.

That brings me to the second point, did you make sure the correct thermoster has been set up correctly in your firmware? otherwise you may have to ditch the amplifier.

Check out Marlin Anet A8 config · GitHub for some Anet A8 Marlin settings