I am struggling in trying to print a fairly simple part: a simple helix. In this picture, you can see how Cura (in this case, but I tried Slic3r and Simplify3d with the same result…) slices my model and computes the paths:

It looks like you model doesn’t have any thickness set in the middle part. Would you mind sharing the STL so we can have a look?

That section missing is most likely thinner than the nozzle diameter. So it doesnt show up. Or theres a problem with the geometry of the stl. What program was used to create this?


Hi and thanks for your replies!

It was designed using FreeCAD (I am a beginner in 3D design -> less than a week, basically, when I got my printer… :slight_smile: ) So Maybe I forgot to handle something.
I thought it could be because of too thin walls, or too large nozzle. I tried different layer heights in Cura, I even changed my nozzle to a .2mm and printed with the finest settings possible

I tried using Slic3r, I tried with some online slicing software I forgot the name…
I also added a central rod to my design, hoping it would solve the issue, but the gcode puts some kind of v-shaped crack in the rod, so one side of the helix is never connected to it… (c.f. picture)

I’m really looking to your feedback at this point!
19_helix_norod.obj (55.8 KB)
19_helix.obj (64.4 KB)

Hi again!
Actually @Oscar_svensson, your comment got me on the right track thanks!

I redesigned the part in FreeCAD. This time though, instead of drawing the whole helix at once, I started with one side of the helix (the radius instead of the whole diameter) and then the second part. This way, the solids that are generated both have no areas without a thickness, and put together, they merge just fine when generating the STL!

A not-so-obvious workaround maybe but it did the job :slight_smile:

Thanks again!