Hello all,

The fact that I am here means I am at my wits end. I cannot figure this out for the life of me. I am in need of your help.

I received my first 3d printer about a week ago. It’s a Creality CR-10. After I figured out how to use it, I was getting really good prints but I always had this ring around the bottom layers that was rough. .4 layer would not produce the rough layers, but anything under .2 would. The included images are mostly .12 layer height. Here are the specs and then what I have tried to fix this issue.

Creality 3D CR-10

Nozzle .4 mm

Hatchbox 1.75mm PLA (Blue and Black)

What I have tried:
-I switch back from aqua net to painter’s tape to make sure that wasn’t the cause

-printed the same part at different layer height. .2 and up shows minimal. 1.5 and lower gets worse as resolution goes up.

-adjusted distance between nozzle and heat bed from one extreme (too close) to the other extreme (too far where the print wouldn’t even stick to the bed). No effect. Same issue.

-I had a couple of noob moments and scraped the nozzle across the bed. For this reason, I replaced the nozzle with the replacement that came with the printer. No change.

-I adjusted infill from 100% to 50% to 10% to 0%. There was a difference. 100% would be the worst and 0% would cause the least, but the over extrusion was still present.

-I changed from Cura to Slic3r but had the same affect.

-I disabled a bunch of features for one of the prints. Anything that I didn’t need, like retraction or z-hop, I disabled. Same issue, no change. I understand I am a little vague on this so I can perform more tests on request.

-Changed the heat bed to 0 degrees. No change. 60 degrees. No change.

-Sent Gcode command for 100mm filament. Measured 95mm. After several attempts, the closest I could get was 102mm. Figured, that was close enough.

-MOST NOTABLE: removed the bottom from print and the over extrusion was barely noticeable. You could still see there was something going on there with the lines but no blobs or bulging. I am not sure what to make of this or how to use the info to fix it.

I have tried changing a ton of settings in Cura, but I have to admit, I am still learning. I am technical in nature with electronics and mechanical stuff, but since I am new to this, I am probably making a noob mistake.

I was going to post some g.code but I have a mess of files. I am currently printing another benchy so I can post the g.code and the project file. Actually, what files should I post that would help you all determine the cause?


Hi, @runout74

I had written up a long answer, but for some reason when I hit submit - it got deleted.

Anyway here we go again:

1. Join the following FB groups/forums:



2. What material are you printing with?

3. What temperatures did you set (extruder/bed)?

4. Check if your glass plate is bent or not (this is a common issue with the stock glass included).

5. Upload your gcode.

Thanks for responding.

1. I have joined and been approved for the Facebook cr-10 group. Should I post this question there instead? I am thinking it might be a better place.

2. Printing with Hatchbox PLA (Blue and Black)

3. I have tried extruder temps 195, 200 and 205 with same result. I have tried bed temps 0, 45, 50 55 and 60 with same result. The last print I just did was 205/60 and it had the same result. Since I opened the box and assembled the printer, every print has had this problem.

4. My glass plate is not flat when I use the included clips. It causes a high peak in the middle. If this could be the cause, what could I do to test? I could take the clips off and tape the glass to the heat bed.

5. I have uploaded the gcode from the last print and an image of the result.


This is what I was printing. https://www.thingiverse.com/thing:1159886

By your write up it looks like you did a lot of changes with no good results. I found a slicer that works very well with the CR-10 and that slicer is the Cura 15.04.6. The new versions of Cura have problems dealing with the CR-10.

I have the CR-10 and resolved the issues by doing the following:

  • You need to start with a baseline first. This is a starting point where you can fine tune your printer
  • Download and install Cura 15.04.6
  • After instillation load your STL model
  • In Cura click on “Expert” and select “Quick Print”
  • A new dropdown menu will come up, select “PLA” and just below that menu select “Normal”
  • Now go to the top and select “Expert” and this time select “Full settings”
  • Now you have constructed a Baseline to work with
  • With the “Full Settings” menu displayed, you only want to make the following changes
  • On the menu in the “Speed and Temperature” make sure you have the following settings: Printing speed = 50, Printing temperature = 225, and Bed temperature = 70
  • In the Filament section of the menu make sure your Diameter is 1.75
  • Finally in the Machine section of the menu make sure your Nozzle is 0.4

Do not use any supports or platform adhesive, make sure this is unchecked. Cure will automatically generate a skirt for the initial pass of the print head

Keep in mind with Cura or any other slicer when you make a change in one field it calculates changes in other fields. Using a baseline approach, as shown above, will correct your errors.


Sorry for the delay, but I found that my Z axis stepper motor is missing steps. It is missing steps during a z-hop causing me to lose entire layers randomly throughout a print. I am waiting for a replacement and it should be here today or tomorrow. I figured I should wait before proceeding since this may be the cause of my problems.

I did follow the steps you recommended. I did them exactly as you stated. I get the same result. If this setup works for you on your CR-10, then it is reasonable to say that my problem is hardware related. Once I get the new stepper motor replaced, I will re-run the baseline test and report back here.

One thing to add is to keep layer height below about 75-80% of the nozzle size.

Hey runout74,

I’m actually having the same issue with my prints. Same printer, same blue hatchbox pla. My printer unfortunately resides not at my home so I don’t have as much time to fiddle. I had a couple thoughts though.

I have sat and watched some of the lower layers print. For me, it looks like the lower layers are extruding a ton of plastic. So much so, that the nozzle needs to plow through the plastic when returning to lay the next layer. But it isn’t consistent across a layer, some spots are higher than others. So my initial thought is that we need to decrease the extrusion multiplier for these lower layers, then adjust it back to 100% when it starts printing the infill/wall layers.

This also doesn’t feel like a bed leveling issue to me. Mainly because the bottom layers of my prints look marvelous. Neatly spaced rows of filament adhering to the bed.

My other thought is whether it is tied to the part fan. My default settings were to have the fan ramp to 100% up to 0.5mm. Have you tried having it ramp 100% sooner than that? I haven’t but am planning to try this next along with the extrusion decrease.

Side Note: I’m running with CURA 2.6 and just had a nice looking 15 hour print. Aside from aforementioned lower layer issues. Those still exist. :frowning:

I believe you are right about the over extrusion at the lower layers of the print. I believe the software is programed to do this by design to help with adhesion. Unfortunately, this causes a side affect when printing at high resolution on the CR-10. With that said, I don’t think the answer to the problem is as simple as changing a setting. I have learned a lot since I posted this question. It has been a learning experience.

The following is what I have settled on as the solution. There may be a true fix for the issue, but I am no longer looking because I am happy with the prints I am getting. I also ordered another printer (different model) that I will be able to compare prints with. For now, the following is what I have settled on. I hope it helps.

1. One of my tests was to try all of the slicers apps and see if there was a difference. I tried Cura, Slic3r and Simplify3D. As soon as I tried Simplify3d, my prints got better. I have no idea why, but the blobbing was not as bad. I have been using Simplify3D ever since. I work with computers for a living and have experience with software in general. Simplify3D is quality software. I hated dropping the $150 for it, but after using it exclusively, I have no regrets. The “Customize Support Structures” feature is worth the $150 all by itself. I do understand that $150 is a lot of money. This is just one of the steps that helped with the blobbing.

2. The second thing that helped was realizing that I did not need to print everything in super high resolution. As I said, I work with computers and when I heard that .06mm height is “better” than 0.2mm, the first thing I did was crank the settings to .06. I believe this was my first, and most significant mistake. I now believe it is not necessary to print at “Insane” resolutions. Ever since I started printing at 0.2mm, I have been happy. See attached image. This was printed at 0.2mm. In my opinion, this is a beautiful print. If I need better resolution for a print, I use Simplify3D’s multiple processes and print the specific layers at higher resolution while the rest of the model is at 0.2 or 0.15mm. I think I just had to learn the limits of my printer. I still print at .15 and .1 sometimes, but I know what to expect. I will get a little bit of blobbing on the lower layers that will need to be cleaned up. Since Simplify3D made the blobbing less of an issue, I think I can live with that.

The following is what I have found to NOT be the issue.

1. It is not in any way related to HEAT. I have printed with 0 bed heat all the way up to 84 degree bed heat. I have printed a ton of 20mm cubes with different nozzle heat from 185 all the way up to 230 and higher. Heat is not the issue.

2. It is not the bed level or height from nozzle. I have printed a ton of 20 mm cubes and tested bed level. I intentionally printed with an unlevel bed and then of course I leveled the hell out of my bed. No change. I also printed with the nozzle too close and incrementally farther and farther away from the bed until the part no longer stuck to the glass. This is not a bed issue in any way.

3. I have tried Hatchbox PLA, eSun PLA+ and eSun PETG. All have the same blobbing at the bottom layers when printing at higher resolution above 0.2mm.

4. I changed the extrusion multiplier from .80, .85, .90… to 1.15. All prints had the blobbing at the bottom layers when printing at higher resolution.

5. I eliminated retraction, Z-hop, and any other feature that I did not need for the print. Same issue.

6. I changed First Layer Height and First Layer Width to 100%. This did help a little, but the blobbing was still there.

If you do find a true solution, let me know. :slight_smile:

I should have added that when I print at 0.2mm, I see no blobbing and the bottom layers are perfect. When I print at .15mm I start to see traces of the blobbing. The higher the resolution the worse it gets.

I also forgot to mention, if the part is 100% infill, the blobbing is very bad. If the part is 0% infill then the lower layers are perfect with no blobbing. This may help if you decide to pursuit a true fix, and not just a work around like I am doing.

Let me know if you have any questions or ideas.

Woody, one thing to look at is how the filament is extruding through the nozzle, i had noticed if their is any friction on the inner metal tube wall (the metal tube is located about the aluminum block that the actual Nozzle screws into, on the aluminum block, at one you screw the nozzle and the other end is screwed into the metal tube.), if their is friction you will get blobbing. Also note that when running a print you may hear some what of a clicking sound now and then at the extruder stepper motor. this is caused by having too much friction (blockage) within the extruder tube, (not the nozzle). The quick fix to this problem is by doing the following: NOTE you will be doing steps 2 through 8 with the extruder preheated to 220c.

1. preheat your hotend to about 220C

2. remove the filament

3 remove the nozzle

4 using a drill bit approximately 0.4 or 0.5mm see if you have clear passage up through the opening where the nozzle was removed.

5 if you can not push the drill bit up, then twist the drill but into the clogged filament plastic inside the metal tube and then pull down to remove the plastic.

6 you may have to do this several time to clear the blockage.

7 once the blockage is removed, reinsert the filament like normal and feed the filament by hand all the way through the bowden tube until you see the filament come out of the hot end, (note you are doing this WITH OUT the nozzle being attacked, you wan to see if their is clear passage through the metal tube with no friction)

8 Once you have successfully achieved good results you can now reattach the nozzle.

NOTE: this is a temporary fix to the problem, the problem occurred because the inner extruder tube does not have a low coefficient of friction allowing filament to build-up on the tube wall and then prevent flow of the filament.

one solution to help correct this problem is to upgrade the hotend tube and extruder nozzle to something like Micro Swiss or similar that is a steel tube having a low coefficient coating.

Did you by any chance try loosening the wheels on the rail opposite the z stepper? I found this post on reddit, but as stated above can’t immediately make a change.

Unfortunately, I’m not entirely sure what the OP is describing when he says he “loosened it up” seems kinda vague. I posted a comment there to try and get some clarification.

Edit: Seems like OP posted a bit more detail later in his post.


Wow!!! Great info. I have to admit, the first thing I did when I got the printer was to tighten all the rollers. It was recommended by several YouTube videos. I may have caused this issue. Ugh! The post you found makes perfect sense. Since I tightened the rollers, I bet the side opposite the stepper motor doesn’t move right away until enough pressure is applied to get it to roll. This would reduce the Z axis movement at the nozzle. This would definitely cause over extrusion at the lower layers of a print. I believe you found the answer!!!

To fix the issue, do the opposite of what they say to do in this video. The link will take you straight to tightening the rollers. For me, tightening the rollers is what caused the issue. If you tightened them when you got the printer, you will want to loosen them back up. If you didn’t tighten them like I did, they may still be too tight. Specifically, loosen the rollers on the right side of the gantry. I attached a picture for clarification.


Thanks again for finding this.

1 Like

Awesome! Thanks for the clarification. I should be trying this out in the next week or so. I really hope it fixes the issue!

The fix is confirmed. I took the bracket off of my printer and figured out how to tighten and loosen the rollers. I can see how I made my mistake. I didn’t understand how to properly tighten the rollers. There is only one adjustment screw that needs to be adjusted. I have attached a picture for clarification. This fitting is intentionally off center. It doesn’t need to be tightened, just turned. On mine, I turned the fitting until the roller was very loose. Then I slowly turned the fitting until the roller came in contact with the vertical support post. I tightened it a little bit more until the roller felt like it was grabbing on.

I started a test print at .06mm layer height. I stuck around until the bottom layers were printed. Looks perfect with no blobbing or bulging at the bottom. :slight_smile: I will post a picture when I get home.

Hey Woody! Not to be pushy, but I’m quite eager to know if it worked on your next print?


Success!!! The lower layers are perfect!

On a side note, I am seeing some ringing on the X and Y axis (see pic). I may have loosened the roller too much (or I’m printing too fast at 50mm/s). No biggie. The ringing I can fix.

Now that the issue is fixed, I am planning on reprinting everything I have ever made. Most of my prints have the blobbing ring around the bottom.

I hope this fix works for you as well.