I thought I’d have a go at making a print controller using Octoprint and the official RPi 7" touchscreen. I’ve got the latest version of OP to work OK and the screen works in terminal mode but I can’t get it load up a GUI. Changing the config in raspi-config to use the GUI tells me to install lightdm but after installation I then get messages about .xsession files missing and round and round I go.

I guess what I’m asking is if anyone has done this and has a good guide to doing it. Much of the content online suggests that TouchUI should pretty much work “out of the box” now once active, but it’s not what I’m finding…


Do you have any other scripts/programs you can run with the RPi and the screen to ensure that the screen/Pi interface is working properly?

1 Like

@Enza3D my Linux skills are weak, I’m afraid so I wouldn’t know. However, the screen appears to be working fine; it displays text and colour OK and when the lightdm GUI failed to load, it did actually show a graphical interface for the failure message and the touch-screen part worked (I was able to dismiss the message by touch) so I’m pretty sure it’s OK.

It feels like something is missing. This screen is used all the time by people running a more normal build for the Pi (Raspbian, whatever) so it feels like it’s more likely to be something missing from the Octoprint build, or something that I’m supposed to add/configure manually, I just haven’t any idea what…

1 Like

The repository for TouchUI is found here on Gihub; maybe try shooting the designer a message and see if he can point you in the right direction?

The interface should automatically work once it detects it’s being called on a touch device, so it does seem odd that you’re having issues. You could also check out the configuration wiki for TouchUI here, and see if that sheds any light on the issue. What build are you running?

1 Like

I think the “called on a touch device” is my main issue, how do I call the Octoprint interface from the command line? I’m running the latest version (I think) octopi-jessi-lite-0.13.0

1 Like

I tried something similiar once and didnt see a way to get octoprint gui to load automatically. I just use a cheap tablet now and connect to the octoprint via wifi on it


I’m going to experiment with this interface over the weekend with my Pi, and will report back on how it goes. I have a feeling it has to do with the way the devices are/are not recognizing one another.

I did see discussion about this on a forum at some point, let me try and find that and I’ll link it here.

Thanks @Enza3D any insights you can offer would be very greatly appreciated.

I’m the creator of TouchUI. Did you follow my Wiki? Did you install Chromium and tested if it’s compatible with the pre-installed kernel? The Wiki I am refering to is: https://github.com/BillyBlaze/OctoPrint-TouchUI/wiki/Setup:-Boot-to-Browser-(OctoPi-or-Jessie-Light)

Hi @DragoslaV thanks so much for replying. No, that’s one page I didn’t find! It looks like a good guide and includes steps I’ve not seen before. I’ll give that a go over the weekend. Thanks again for replying here.

Hi @DragoslaV I finally got around to playing with this again and it works! Your guide was spot on (don’t know why I couldn’t find this myself the first time around). Boots into TouchUI now, touchscreen works, etc. Greatly appreciated.

I haven’t actually set up any printers yet, but that’s (presumably) mostly just config and can be done via the web interface.

Hopefully I’ll have time to get something printing today!

for the life of me I cannot get your guide to work. It boots up and when it goes to load the desktop, all I get is a black screen, sometimes with a mouse cursor. I’m using the rpi 7" touchscreen if that matters.

There is currently an issue with the Official RPI touchscreen device. I haven’t found the solution yet but please keep an eye on my issue tracker. I don’t own the Official RPI Touchscreen, so I am depended on information from the field.

More about this: TouchUI won't boot on fresh OctoPi, RP3 and Official Foundation LCD · Issue #98 · BillyBlaze/OctoPrint-TouchUI · GitHub

The issue have been resolved.