The Objet30 Prime that I use for work had worked flawlessly. However recently it started popping up these error messages: "Head Heater does not match required temperature " & “Pre-print error: Head Heater temperature timeout (-10101) end print”.

Does it mean the printing head is malfunctioning? Could it be fixed, or maybe a printing head replacement is required?"

Many thanks!


Hi jason, it can be a veriaty of issues. If u need any parts you can maip me on I can supply parts at reasonable prices

Hi Jason, I had that error a couple of times. It was a bad print head - either the heater or the thermistor was broken. Replacement was the only option. Too bad they’re so expensive!

Not that expensive if you purchase from me :slight_smile: Send me a mail and lets see what we can do

Hi Nick,

Thanks the reply! I am also suspecting something wrong with the the heater or the thermistor, or the controllers for them.

Actually, the head temperature readings, both model and support, could rise up to 64 degree Celsius during the preprint heating process, but never exceed that temperature ceiling. The printer requires >=65 degree Celsius for the printing heads during preheating to proceed to the subsequent printing step. After like 20-30 minutes stay in the 60-64 degree Celsius range, the printer would quit the printing/heating process and prompt the error message.

I am only 1 degree Celsius short of a good printer. This really makes me frustrated.

Hi Nicky,

Thanks for the reply! Where are you based?

Do you have experience with printer problems described above?

Hi Jason,

I know, you’re question ist already 7 months ago but maybe some other user finds this thread, so here is my answer:

On my Objet 24 I had the same problem, The temperature goes up and down but never reached the correct value of around 71 degees celsius.

First I tried the not so expensive way and just ordered a new thermistor from Stratasys (it sits under a little black sign in front of the heating block). It costs me around 30 EUR (totally crazy for an electronic part but I found no compatible type).

it is somewhat difficult to fumble the connecting wires in the plug but I managed it and - voila: temperature ist shown correctly and printing works.

Perhaps this is worth a try before a service technician exchanges the whole heating block.



I also ran into this problem and after some back and forth with tech support, I was told to look through the maintenance window which I accessed by pressing Ctrl+Alt+M while on the Objet30 Prime operating system and viewing the window which shows the head temperature and figures for internal sensors. Once there, a tab called “maintenance” showed up right next to the “Options” tab. From there, I selected the option of “Calibration” and was prompted by a screen which displayed the “Requested Voltage” vs “Actual Voltage”. My requested voltage was something like 24 or 25 V while the actual was like 0.16 V.

From my conversation with GoEngineer, they stated that the likely cause of this was “the cable connecting the lotus board to the spartan board”. Apparently this controls the XY motors and supplies the voltage to the print heads. The explanation I was given to why this cord failed is that over time as the x and y axises move back and forth, the cord deteriorates over time and eventually fails. I am having someone come in to service my printer and I was told its quite the ordeal to fix. To be specific, I was told it would require taking off multiple covers, the entire top and multiple other components while replacing fuses and running a new cord in a specific orientation.

Without taking my printer apart, does anyone know where I can find any illustrations/schematics showing where exactly these boards and cord are located? That would be super helpful for me to understand this problem.