We’ve got an Objet 30, V3 from 2015, that has been working fine until recently. Now it is no longer connecting to the software. There is no light or anyting. In other words, its seems completely dead. Any suggestions or similar experiences on this forum?

We’ve gotten an offer from a service provider to replace the motherboard, incl. labour, for approx 50 000NOK which is about 5000 euros. This is a lot of money, so we are wondering if it is worth it for this machine, which is already some years old.



Good morning. Not a nice problem to have! I have had this issue before with two Objets and I wouldn’t spend €5k just yet! Can the provider not give you any advice that might help you remotely? I suspect that this is merely a cabling issue. Check all of your connections, make sure there is no damage/ loose fittings. Has the machine been off/ powered down? Was there a power cut? If so, shut everything down, reboot and make sure the machine is switched on first, then the computer. When this happened to me, someone had stood on my cable and the connection was broken. I hope this helps. Good luck!

100% Agree with Chelsea Rae. First check all external connections. Then open her up and check internal connections starting with the power supply. Our Uprint started reporting sensor errors and it was eventually traced back to a single crimp connector with a broken wire on the power supply.

Once we’ve had this issue and were about to replace the OHDB because of no connection issues. Have you tried the obvious restart/reset from the internal PC? We had to completely unplug our 260V in order to restore connectivity problems.

Thanks for all your responses. I will try replugging / rebooting / changing cables on the machine and try again. fingers crossed.

I have tried several computers, new network cables, new power cables etc. I have also looked briefly at the motherboard to see if there is any contamination. but, nothing…

It seems the built-in computer is completely dead. When i look at the ethernet connection to the host-pc, it even says there is nothing connected.

Any other advices out there? I am located in Norway, and Objet service technicians are quite scarce (apart from the one suggesting i do a 5000€ repair). Anyone here know of an objet service technician which is available by phone?

Man, that sucks! It sounds like the internal PC is kaput! The best supplier I know is in the UK, they are called Laserlines. Avoid Tritech or Stanford Marsh, they try to charge higher prices. Ask for Peter, he is the technical guy. Here is his email address; peters@laserlines.co.uk. If the computer needs to be replaced, I’m afraid it will be in the €5k region. Bad luck, I feel it for you. I hope you get a result.

Thanks for the advice, i’ve reached out to him.

fingers crossed…

Have you checked the internal power supply?

It could be your printers internal hard drive. Is the printer itself still producing noise? Does it still Idle or is it completely silent? You could try hooking up a monitor to the back of your printer (near the power off switch) via a VGA cable and see if you can get to the windows backdrop of the internal computer.

I tried connecting to a screen via VGA, but it does not produce any image. also, when turning on the machine there is only the fan from the power supply.

My gut feeling now is a faulty power supply, as rmigliac suggests. I will try with a voltmeter, or contact my local objet support to request a new power supply.

Do you have a local computer repair shop? Bring your hard drive and get a new power supply. This happened to me last year. Cost me €100 to fix. At least they could eliminate it if it’s not the problem and it hasn’t cost you too much?


I tried with a multimeter, and it seems as if there is no power coming out of the PSU (see attached image). I also tried to check the current on the cable in top left corner of the internal pc (“to PC board”). No current there either.

Am I right in saying that the PSU is faulty? Question then is, how to take out the PSU. I tried opening up the front panel on the objet (next to print material drawer), to see how the PSU is connected to the stratasys board. A daunting sight to say the least. Are there any tutorials out there? or schematics of the cables at least?

Still, i would rather spend days detaching all the cables instead of paying 5000€ ++ for someone else to do the same job.

Sounds like the PSU is dead but to make sure, check the voltage (120/240) going into the PSU. If its present, then check for fuses on the power supply itself. If those are good, then its a good bet that the PSU is faulty. Perhaps you can order one and replace it yourself?