HI …new here and new to 3d printing.

I bought a Kossel delta DIY kit a few weeks ago and assembled the machine with no problem. It has an Arduino Mega 2560 board and I have downloaded the Arduino software but the driver which is supposed to self install won’t load. I bought a driver from Driver Genius and downloaded, but my Control Panel device manager can’t find it. I also downloaded the driver from the Arduino web site but still no luck. I’m using a windows 8 laptop…is there a compatibility issue? Hope I’m providing enough info here to elicit a solution. Any help appreciated.


1 Like

Install arduino ide, and upload firmware with the ide, if you are working with the firmware source

Which driver you need depends on what serial-to-USB-chip is on the board. Most cheap Chinese Arduino-boards nowadays uses the CH340-chip instead of the official Arduino-chip so that’s probably what you should be looking for.

Here is one link I found which has the CH340-driver for Windows 8 available for downloading and some instructions on how to install them. From my own experience you usually also need to reboot your computer after the drivers have been installed for them to work properly.

A side note: drivers are always free so you should never have to pay for them.

Edit: I forgot the actual link. Here it is:

Good advice, Of which I too may have to follow if I have to switch to a windows box. I have the same issues as Bob, but cannot get ANY software to recognize my printer on my Mac running OS X Mavericks. Software sees the printer on USB, but refuses to connect. Exact same hardware and cable plugs into my roommates pc laptop and it seems to work ok (haven’t printed anything, but manually moved the print head and such around.) Tried Cura (works on pc), Matter Control, and Repetier Host. No joy.

Any thoughts?

It could still be a driver issue. Have you installed the correct drivers? There are many different chips used on Arduino boards including CH340, FT232RL and Atmega16U2, but there may be others as well. To make sure you get the right drivers you should read the model number on the chip closest to the USB-port and get the appropriate driver. The FT232RL should be supported out-of-the-box in most OS:s, the ATMega16U2 requires Arduino’s driver and the CH340 requires it’s own driver as mentioned.

Thanks. Ill have to research it some more. I’ve never had any driver issues on a Mac in the 20+ years i’ve owned them. They are known for specifically NOT needing to install drivers with new hardware. Confusing.