I’ve been asked by a local elementary school to have a look at their Replicator 2. It seems that when powered, the up/down/left/right buttons don’t function. I’ve tried cleaning the contacts and as well as shorting them with a paperclip, but only the “M” will operate. This makes doing routine functions difficult.

Using the Makerbot application I’ve been able to perform a factory reset to level the bed and load filament, but that application doesn’t replace all of the functions on the control panel. I haven’t tried the updated Makerbot Print, as I understand it’s not compatible with the Replicator 2.

I’m wondering if anybody has suggestions on either a fix for the buttons, or a software that will let me emulate the buttons or bypass them completely. I’ve taken a look at Simplify3D and it seems to be able to perform some functions but may be a little complicated for an elementary school. The ideal scenario would be for the school to be able to print and perform functions right from the panel, or for a piece of software to send the up/down/left/right/“M” commands from a simple interface.

Thanks very much.

It depends on what failed. Its possible its just the rubber button pad itself, cleaning them won’t do much good, the gray paint they put on the contact points of the rubber pad fails to be conductive after a while. I fix a lot of them by buying these little conductive pads from China for fixing TV remotes and gluing them on, works great and they seem to last almost forever compared to the painted conductive surface they had from the factory. But sometimes the buttons not working is also a sign of a failure on the front display.

Makerbot sells the entire front display unit for about $80, so you could swap the whole thing and see if that fixes it. I fix quite a few of these front display units, most of the time its a couple failed IC’s on the board that need replacement.