i’m completely new to 3d printing.

I’m using an arduino uno and the teacup firmware. I had some trouble opening teacup after I downloaded it. I downloaded the Teacup firmware master branch package.I followed the instructions on Rep Rap wiki but i didn’t understand how to set it up. I also downloaded python. Can someone please tell me how i can open teacup and use it with my arduino uno r3?

Thanks a lot, Mitch


You need python installed, on your path and associated with “.py” files, so that python starts when you double-click on the configtool.py file. Where did you get the version of python you installed?

If python is at least on your path, open a command prompt and navigate to the directory where you extracted the teacup firmware, then enter “python configtool.py” on the command line.

Hi thanks for answering,

I got python from here. You mentioned getting python on my path. what is that and how do I do it? I am completely new so I don’t know anything. Then how do I open a command prompt? and how do I enter Python config tool.py on the command line?

What I did was basically this: I downloaded the teacup firmware from here, and then downloaded python version 2.7.12. Then I went to the Python file “configtool” in the teacup firmware, and double clicked. the python window, if i’m not mistaken, opened for a fraction and then went out again. How can I open it?

Thanks a lot in advance, mitch.

Make sure your librarys have uno in it. It may be easier just to use Arduino 1.0.4 upto 1.0.6 as it is an Ardunio board and has the librarys installed already. I have it on my WordPress blog https://georgeroblesjr.wordpress.com I have two versions on the first blog. Can also download directly from Ardunio site as well.


thanks for replying but i’m not sure I understood what an arduino 1.0.4 is. And Where do I need to Install the libraries?

And the firmware on your site, is it compatible with an arduino uno r3? And one more thing, what can you download from the arduino site? please reply asap.

Thanks mitch

Arduino.com Look in search for version 1.0.4 The firmware I’m running is ramps and a mega essentially. Firmware has multiple boards in the tabs. I also have some videos on how to do it. If the r3 is not in library, then you can add it. There are tons of video on how to do this. The Arduino dev software is what I use to write and edit sketches directly to the board via a USB cable. However as its progressed over the years, the library for the lcd has changed among other things. Which is why you need the older version of Arduino. Arduino library is easy to update via Windows explorer and restarting the Arduino program. What you see on my blog post is multiple items. Read the descriptions to know what they are. Also georgeroblesjr is my YouTube user name. If you Google mk8 autolevel you will see my videos pop up as well as my thingiverse files.

1 Like

after i’ve installed the version 1.0.4, and added the uno r3 library, what do I do? how do I upload the firmware?

Wait, the firmware your referring to is your firmware? or teacup?

thanks again

I’m going to go over this from the start - apologies if this is a little simplistic. I’m also assuming you’re using Windows.

Prerequisites: you will need the Arduino IDE (IDE means Integrated Development Environment) installed first, which you can get from here: https://www.arduino.cc/en/Main/Software

1. Find the teacup firmware file you downloaded (it should be a zip file) and double-click on it to open it. You should see an explorer window open with the folder “Teacup_Firmware-master” visible.

2. Open another explorer window. You can do this by pressing ctrl+enter then typing “Explorer” (without the quotes).

3. In the new explorer window, click on the C: drive on the left hand side, then on the “New Folder” option at the top of the window. Give the new folder a name, such as “temp” (without the quotes).

3. Double-click on the new folder.

4. You should now have two explorer windows open - one with “Teacup_Firmware-master” in it, the other open in the new folder you just created. Click and drag the “Teacup_Firmware-master” folder to your newly created folder. This will extract the zipped-folder to your hard drive.

5. Once the firmware has been extracted, close the explorer window you dragged from, leaving the window you dragged to open.

6. Double-click on the “Teacup_Firmware-master” folder you just extracted into C:\temp to open it, then double-click on the configtool.py file.

This should start the config tool. If it doesn’t, carry on from step 7 below.

7. Open a command prompt by pressing Ctrl+Enter, then typing in “cmd” (without the quotes) and pressing Enter.

8. Change to the temp directory you created by entering the following commands and pressing Enter after each one:


cd \temp\Teacup_Firmware-master

9. Enter the following command and press enter:

python configtool.py

If the configuration tool does not start, you should see an error message. Copy it and reply with it here and we can figure out what’s going wrong and move on to next steps.

1 Like

As stated before not tea cup, I run ramps and a mega basically. The Arduino will allow to upload firmware of your choosing. Plug in USB, under tools, set board, comport which is the USB port your plugged into, and set programer to Arduino as adk. Then hit the upload button, you will see sketch compile and then should upload.

Thank you so much for giving me such a detailed explanation. (nobody else could tell me this!). A simplistic, detailed explanation was exactly what I needed.

Will teacup firmware (on the arduino uno r3) work on repetier host? If it does is there anything extra I need to do to make it work?

I didn’t need to go to step 7. I guess it wasn’t working before because it wasn’t in the local drive c.

I just opened the configuration box 2 minutes ago, and I may have some more questions. can we keep in touch trough email? or on 3d hubs? Email is easier for me but I can manage anyhow.

Thanks again, mitch

Uh oh, ran into another problem:(

After I opened the configtool, i went to file, choose printer. So the printer I have is my own, in the sense that I designed it and made it. didn’t buy it. Now what printer do I choose?

Then when I go to file, choose board, the arduino uno r3 isn’t on the list. Which one do I choose so that It’ll work?

Also when I go to edit, then settings, It asks for the arduino directory. how do I give it?

Can you also help me in configuring, like sharing a site where they show you how to do it?

I’m sorry I ask soo many questions. I’m a complete beginner and don’t know how to do anything :slight_smile:

Thanks again, Mitch

Hey guy, there is tons of these instructions on here. (In response to your comment of no one could help…) Please give thanks to all. That’s what we’re here for free. Share Information. We all try to help to a certain extent. Some help more then others. Life’s journey is usually what prevents long answer from me as well as others. I sell tech support myself. But still try to help in free time. But why not look up on thingiverse the teacup printer? Has all instructions, files, firmware, frame drawing as well. And many, many comments. Not to mention the vast amount of info on 3d hubs alone. If you would like a one on one via Skype, I can explain much more. Links to my store is on my channel page, as well as my blogs and firmware. So I try to do more but time is limited. Good luck with it all. I meant no offense but had to voice my opinion after that little line of “no one could tell me this…” This is an open source project. Lots of info is out there if you look. Like snyc all z axis motors, some have used belt, others just multiple steppers. Some add panels to enclose chamber, laser engraver, laser and resin type printing, etc.

Hi, I’m sorry for not being specific.

there were these other forums i signed on to and asked the same question. the people there just didn’t answer my question. they kept going round and round it. when I said "no one could tell me this, I was referring to the guys on the other forums. I’m really sorry for the for not being clear. Besides, your website and youtube channel helped me to work this out. I wasn’t referring to the you guys on this forum. And believe me you guys are the only reason I want to continue on my project otherwise i guess i would have given up. So please don’t doubt my appreciation for the time you give this.

Anyway thanks a lot, and please keep in touch so i can ask more questions :slight_smile:


george@georges3dprinters.com Work email.

thanks a lot, will keep in touch

Hi there. I realize this is an old topic but so far it’s been the best resource for me as I try to get teacup setup with various issues. I’ve gone through most of the steps listed here and elsewhere to get python setup, get wxpython going, Arduino IDE, and the teacup firmware but it’s not working yet. I went through the process listed about and got to the point of running python configtool.py but keep getting an error from there. The error is:
TypeError: Sizer.AddSpacer(): argument 1 has unexpected type ‘tuple’

Looking online, it seems like the problem is installing the wxpython with pip but I’m unsure how to install it otherwise. Has anybody had this issue or solved it? Thanks!