Hi Guys,

Just got this printer the other day, and I’m just having some trouble getting decent prints. For my first test-print I"m trying to print this guy: Westhighland white terrier by angry_elf - Thingiverse. Since I run Linux, I’m using OctoPi (much better than the official software, which I tried in a VM), but I’m struggling to find a good cura profile. I printed the first one using the default Cura profile for M3D PLA, and got this:


Not bad, but some obvious issues. First, some of what I think is called pillowing. You can basically see through the top layers. The strands are too thin across, and the gaps between the walls and the infill isn’t great. Overall, this is the best print I’ve had, and the only full one. Additionally the raft has some bad stringing, but there given the geometry of this print that isn’t really an issue.

The most recent print I tried with these settings. I upped the temp (slightly) and flow rate, and tried to make it more sensitive to retraction given the stringing.

machine_depth = 107.0
has_heated_bed = False
extruder_offset_y1 = 0.0
extruder_amount = 1
machine_center_is_zero = False
extruder_offset_x1 = 0.0
machine_shape = Square
machine_width = 108.0
machine_height = 112.0

solid_layer_thickness = 1.800
wall_thickness = 2.100
fill_density = 12
fix_horrible_union_all_type_a = False
fan_speed_max = 63
nozzle_size = 0.35
support_z_distance = 0.15
skirt_minimal_length = 0.0
overlap_dual = 0.0
cool_min_layer_time = 2.5
support_dual_extrusion = Both
layer0_width_factor = 100.0
skirt_line_count = False
retraction_amount = 4
travel_speed = 50
raft_line_spacing = 2.0
fan_full_height = 0.301
raft_interface_thickness = 0.2
raft_base_thickness = 0.4
print_temperature = 220.0
print_temperature2 = 0.0
print_temperature3 = 0.0
print_temperature4 = 0.0
skirt_gap = 2.0
support = Everywhere
raft_airgap = 0.35
support_type = Lines
fan_speed = 63
support_xy_distance = 0.7
raft_surface_layers = 2
inset0_speed = 12
raft_margin = 2.0
platform_adhesion = Raft
insetx_speed = 14
raft_base_linewidth = 2.5
support_angle = 50
solid_bottom = True
raft_interface_linewidth = 0.5
retraction_combing = All
layer_height = 0.15
ooze_shield = False
fan_enabled = True
retraction_minimal_extrusion = 0.02
simple_mode = False
filament_diameter = 1.75
filament_diameter2 = 0.0
filament_diameter3 = 0.0
filament_diameter4 = 0.0
print_speed = 35
fill_overlap = False
support_fill_rate = 20.0
retraction_min_travel = 0.0
wipe_tower_volume = 0.0
solid_top = True
retraction_hop = 0.1
spiralize = False
retraction_speed = 35
filament_flow = 120
bottom_thickness = 0.3
retraction_enable = True
bottom_layer_speed = 12
fix_horrible_union_all_type_b = False
object_sink = False
cool_min_feedrate = 12
retraction_dual_amount = 14.5
fix_horrible_extensive_stitching = False
cool_head_lift = True
fix_horrible_use_open_bits = False

cool_start.gcode =
start.gcode = ; Sliced at: {day} {date} {time}
; Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
start.gcode2 =
start.gcode3 =
start.gcode4 =
end.gcode =
end.gcode2 =
end.gcode3 =
end.gcode4 =
support_end.gcode =
replace.csv =
support_start.gcode =
postswitchextruder.gcode =
preswitchextruder.gcode =
cool_end.gcode =

And got this (just the raft, I aborted it after one and a bit layers):


Down the bottom right is the where it started, and I think it was coming out pretty flawlessly. Smooth, no gaps, really very nice and good. But as it continued to print, some issues began to appear. As it went to the top left, you can see some gaps appearing on the bottom layer. The top layer started okay (top left), but as it moves right things went downhill quickly, until it just stops extruding properly at all. At this point I aborted, and I now come to you for help. What settings do yall use for cura/octoprint/M3D? Is there anything obvious that I should change for mine? I’m struggling to find any definitive cura settings aside from the ones that came with M3D Fio. I’d really appreciate any help!

PS. Is there a G-Code for turning off the damn LED? It’s pretty bright, and I’d love to turn it off when I’m not using it.

Hi Daniel,

Have you tried the adafruit M3D profiles ?

Found the link on their M3D-OctoPi article : Overview | OctoPrint on M3D | Adafruit Learning System

Let me know how this does as I’ll try Octoprint / OctoPi sometimes later this summer.

I had a look at them, but given I’m using the stock filament, which is 1.75mm, I didn’t think those would work too well. Do you have a suggestion of which to use and how I should tweak it?

Actually it’s a typo in the file names.

The “M3D 2mm PLA.ini” profile is the 0.2mm layer thickness, but is using some 1.75mm filament.

Just tried it now, but no dice. Printer severely under extrudes and is failed from the get go. I might try it again on a higher temp as this worked better for me before, but I’m not getting my hopes up.

Has anyone used the iMe firmware? I installed it but it throws the calibration off, and it doesn’t know where any of the corners are, etc.

Okay, so it looks like it was an issue with the filament not being fed through the gear properly. I was feeding it internally and I think it was getting stuck inside, so I took it out and now have it fed externally. I’ve also updated the iMe firmware, which is what I’m now struggling with. The bed calibration is WAY off. I’ve tried calibrating it the old fashioned way (the piece of paper technique), and using the G32 g-code. It will try to print too high (like a centimeter off the bed), it only uses half of the print bed, and each time I recalibrate it, it behaves differently. From what I read, this firmware will fix most of my issues, I just need to be able to get it to work properly.


Did you resolved your issues ?

Sorry, I’ve been a little busy this week. I haven’t as yet! I’ve solved my extrusion issues by using it externally (I shouldn’t have to, but I accept that 3D printers are tricky to make). My main issue now is trying to get it to print using the iMe firmware. Literally EVERY time I try to print something, it seems like it calculates a new print area. It’s usually around the left half of the print bed, but can vary up to almost all of it. Whenever it starts printing using the whole bed, it will start the first layer too high, resulting in a really uneven layer, and compromising the rest of the print. Going to do some more tests with the stock firmware to see if my issue remains, but man, it shouldn’t be this hard. ESPECIALLY for a printer whose design ethos is “a plug and play” 3D Printer.

Also, thanks for all your help so far! I really appreciate it!