I recently found a Makerbot Replicator dual extruder( wooden frame) in a free pile - someone was moving and didn’t want it anymore. It is in perfect working condition and even came with two full rolls of filament.

After some research, I decided to download the last version of Makerbot Desktop. However, when I try to print a file I get the error “unexpected error while starting print.”

Next I decided to try updating the printer software. It is currently on version 5.1. But when I try to update there is the error “unknown error from conveyor.” I tried varying the timing between hitting update and pressing the restart button, but it still didn’t work.

Finally I tried to export and print from an SD card. But when I chose the option “print from SD card” on the printer it takes me to a screen where the only choice is “exit menu.”

After that I gave up trying to fix the problem myself and reached out to customer support. They gave me a download link for an older version (3.7) of Makerbot Desktop. I followed their instructions to get rid of the newer version and installed the older one. However, I got the exact same errors as before. I asked customer support again, but the answer they gave didn’t help.

After more research I decided to download the even older Makerware and try it. Makerbot deleted all the download links for Makerware, but I was able to find a download someone had saved on a 3d-printing forum. However, when I connect the Replicator via USB the messages “Replicator Dual Connected” and “Replicator Dual Disconnected” appear simultaneously. When I try to print the file, the “print directly option” is grayed out. I also tried exporting the file to the SD card using the file format recommended for software version 7 and below, but the same thing happened as before.

I also dowloaded ReplicatorG in the hopes that it would work (I found old forum threads where people were recommending it for the Replicator), but it just gives the error “unable to connect to printer.”

Starting to suspect that something was wrong with the USB cable, I tried two other cables and multiple USB ports on the computer, but had no luck. I think that the USB port on the Makerbot is broken, and that’s what is causing the problems, but I want to make sure before I try to fix it. Maybe updating the software on the printer will also fix the SD card problems.

Hello Glyph

Makerbot works with an .x3g file extension that only the Makerbot desktop or Makerbot Print or Simplify can generate (I do not know if there is any new software that allows to export in this extension).

I heard that makerbot is no longer updating its software for the replicator. I’m not 100% sure, but I used to slice with the Makerbot desktop and It used to generate the same problem you refers: “Server error: something went wrong when communicating with the makerbot server …”

My recommendation, being a Makerbot replicator 2x user, is to buy Simplify software. It is not too expensive, but it is by far, much better than the original makerbot software.

Two things…

Did it have the original SD Card with it? If not what are you trying to use for a card? I have three of the Rep 1’s running here and i have fixed multiple others, and i can tell you they are very picky about the SD Card. It needs to be a plain old SD Card, and i mean old, not an SDHC or any of that newer stuff, and it has to be 2gb or smaller, it will not read a card over 2gb. The most reliable ones i have had are the same as the original that came with it. SanDisk white label 2gb SD Card. They are a Type 2 card, on SD Cards look for the little number in a circle on the label, most of the newer ones are Type 10, its the speed of the card, and you need the older card for it to work on the Rep1. Ebay is your friend unless you have a camera shop around, they generally have some older cards to keep older cameras going etc.

Buy Simplify3D, the Makerbot Desktop software stopped working correctly for the Rep 1 a long time ago, it just outright doesn’t work right anymore. At the bare minimum you will need to get firmware version 7.5 on the printer and then you can save to the SD Card from Makerbot Desktop, even the latest version, but its very buggy in the print results, sometimes it does ok, sometimes it misses pieces of the model, etc. I gave up on MBD about three years ago now, and went to Simplify3D, yes its not cheap, but you got a free printer!! Man why can’t i find things like that, busted and beaten ones go for $300 on eBay. The Rep1 is a solid older model, much better then their current printers, the 2 and 2x were good but had their issues as well. My Rep1’s are my workhorses, i have close to 6,000 hours on my first one, the second one is almost 3,000 hours and the third one is around 1,000 hours.

They are cheap to run, cheap to fix, and cheap to upgrade! Well worth the cost of Simplify3D, and trust me, its well worth the investment to get a good slicer like S3D unless you like wasting filament on failed prints!!

As for the USB issue… NEVER print from USB, its a nightmare. Any small computer background service can cause a failed print, the computer going to sleep, locking to the welcome screen, etc. I have seen many things crash the print. The last thing you want to worry about is the computer talking to the printer flawlessly for hours on a long print, use the SD Card thats what its there for.

As for the USB issue with Updating. Get ReplicatorG and do the update with it, but uninstall Makerbot Desktop or at least stop the Conveyor Service first. You can’t update with RepG with the Makerbot Software running, and yes even when you close it there is services for it running in the background. Safest bet is to uninstall it then reboot to clear them out and then try again. Also depending on your printer’s age it may not have got the later revision which added a capacitor for auto reset when updating, its labeled C20 on the Mightyboard near the USB port. It’s a .01uf ceramic cap that goes in that position, all the boards had the traces for it but not all of them were installed.

Last but not least, if trying RepG again after removing Makerbot Desktop still doesn’t work it could very well be a bad USB chip, its the AT8U2 near the USB port, i have replaced countless numbers of them over the years and they can and do fail. But all you really need it for is a firmware update cause as i said printing from USB is just plain pointless.

What version of firmware is on your printer now? When you turn it on it should show you the version number on the screen.

Edit… I see you said its version 5.1… Oh yeah your VERY VERY out of date. Version 7.5 is the latest version for the Rep1, and version 5.1 will not work with any version of Makerbot Desktop, that only works with the ancient Makerware that isn’t really archived anywhere anymore. I would guess you need something as old as version 3, i think there was a later version 4 and 5, those won’t work with your firmware as is.

Since i got too long winded in my last post… Just some additional info…

If you have the skills you don’t need the USB to update the Firmware. You can by a simple AVR programmer off eBay for a few bucks. I have a $3 USBASP that i got off eBay and it works every time. Then you can use AVRDude or if you would prefer a non command line based program get AVRDudess, then you just connect the USBASP to the ICSP header for the ATMega1280 and dump in the new firmware. You don’t even need to fix the USB port if its broken at that point, just get a compatible SD Card and your set to run with Simplify3D with the latest, and last made, firmware for it. There was some custom versions of firmware that work with the Rep1, but save the headaches and just put the stock Makerbot 7.5 on it and call it done. I have almost 10,000 hours combined print time on 7.5, it just works, hit print and walk away, mine run daily.

If you want to communicate with me quicker then via the forums feel free to drop me an email, you will see my posts on here now and then, i do MightyBoard repairs, i work on the Rev E in Rep1’s, as well as the Rev G and Rev H in the Rep 2 and 2x. I could easily dump the firmware in that board if i had it in front of me in a few minutes, or even repair the USB port also.

Don’t give up on the Rep1, its a solid old machine, but likely to need some upgrades if it has its stock factory extruders which were really bad. Upgraded spring loaded all aluminum ones from China on eBay is a $20 upgrade and they become solid performers. I have a Rep 2x as well, but i will never give up my Rep 1’s, they do a huge amount of work for me daily.