Hi everyone,

I’ve got a 3D Kreator Printer: it was working in a perfect way until some days ago.

On Monday, a huge issue appeared: while I was printing, the filament began to come out from the space between the guide and the nozzle. I stopped the print, I removed the filament and I cleaned the nozzle.

I connected all parts together and I tried to print again. This time, the filament was going into the guide but it wasn’t coming out from the nozzle. Honestly, I was surprised since the both the nozzle and the guide was clean so I checked all the connector and I find out this situation:

Is it possible to fix the cable or do I have to change it? If I have to change it, do you know which kind of instrument is needed in order to open the following screw? I think that an Allen key is necessary but those of the standard sizes do not match with the screw.

I suppose that the broken cable is the one that is controlling the temperature and the flow of material, is it right? I jumped to this conclusion considering the nature of the problems that have occurred.

Any suggestion on how to solve the issue or on how to repair the connector will be more than welcome!



1 Like

Hi Federico, that piece is the thermistor, and yes, it controlls temperature. As obvious as it may sound, you will have to put the cables inside the connector again or to buy a similar connector where you can do that.

If the thermistor still work ( most provable ) that’s it.

If not, then you need to change it… you may try using those screwdrivers with an star instead of alen, that may work if you can’t find a proper alen, but be carefull not to do much pressure because you can break it.

if you buy a new one then make sure you ask for a proper way to attach it to the connector since most of the time they came lose.

Sorry for my english is not my native language.

Hope that helps.


1 Like

Hi Gerardo,

Thanks so much for all the information and don’t worry about your English, we’re in two that are using it as a second language!
So, I will try to fix the cable: honestly speaking, I don’t know how to do it but I will try to find some tutorial on internet or I will annoy someone who works in an ironmonger’s shop!


1 Like

Hahahaha, ok!, I’m from Argentina, living in Mexico… I speak spanish but it seems that english is more a universal language…

It seems preety straightforward… take out the rubber cover from the connector and maybe from there is more easy to put it toguether again. It doesn’t seem to be soldered… so maybe the cables just fits inside somehow…

Spanish should be at the same level of Englis, a lot of people are speaking it as first language!
Fixed it! But the problem isn’t solved. At this point, I suppose that the nozzle or the guide is clogged.

1 Like

Well nice to know!, one problem at the time right?.. I guess you can handle a clogg so let me know if after that everything is ok!. There is nothing more anoying but a broken 3D printer!

Hi Federico,

it took me quite time to get here, but now I’m at your command!
So, Gerardo helped you a bit - a big thanks @Gerardo_Oliva - and I’ll take it from here. Please, contact me on my email: support@3dkreator.com so we can discuss the details and work it out properly.

Best regards,


1 Like


Thanks for your answer and for your time. I sent you an e-mail with more details!



1 Like