I have finished putting an flsun delta printer together, however many of the basic functions listed in the instructions cause problems. The steppers do not seem to operate the way they should based on the input from Repetier. It just doesn’t react like a delta printer.

I would appreciate any configuration hints that might help with some of my basic issues, of which some are listed below:

Does anybody have, at least, some sort of suggestion for firmware that works best with this MKSv1.4 board? It doesn’t seem to work well with any fresh firmware, or any of the firmware provided by the seller. They stated it would work right out of the box (assembly required), but it most certainly does not. Just one example: hit home in repetier, and one axis just runs until I can pull the plug. The end stops dont do anything. The motors just pull the arm down towards the print bed indefinitely. It will absolutely break itself if I don’t intervene.

It came preflashed with Marlin, but never worked. I flashed with up to date github Marlin since through Arduino 1.6.11 and it still has problems. It connects, and can be toyed with, but none of the inputs produce output that are accurate to what I expect to see. Its as if the input is ready for a standard desktop printer config, and not the kossel type. Repetier seems to know that I have a round print bed, but it doesn’t give output like it does.

The LCD screen has since turned into a glowing panel of blocks.

There is a lot more to describe, but if anybody can throw some crumbs my way, I would be very grateful.

1 Like

Have you defined it as a delta and not cartesian in the new copy of Marlin?

1 Like

It appears that the configuration.h file shows delta/kossel as the specific type defined.

If the board is functioning correctly, which I am skeptical of, then somewhere in the file I presume the settings just don’t match for typical delta layout.


Manually sending to HOME causes one motor to pull the trolley down to the heat bed until I cut power, etc. Same thing happens if I start a print.

1 Like

The manufacturer has suggested I test the voltage of the x motor connection and report it to them, but they didn’t give me any details about what reading I should get.

1 Like

Have you tried clearing the EEPROM, just to be sure that you are clean flashing?

1 Like

What axis is going down if HOME (G28) is send?

If you have correct Marlin configuration for delta, and endstops/z-leveling are working (test it with M119), and motors are wiring right… it can be faulty driver.

I recommend try to swap drivers for the tower where there is a movement down if HOME.

1 Like