There is no specific point at which it does it, but while printing or just heating up, the printer will reboot. I just updated to the latest and greatest. Before someone says, ‘try an older version’, I tried many of them, still a no-go. I have no idea where to start looking for a cause. I first I thought it was the PS overheating, but the fan kicks on, and the temp stays low on the housing. Thank you for any help.

1 Like

Bad power could do it. Loose connections could and this could get to bad solder joints.

However, in the computer world I would be leaning toward a bad component. Overheating is generally a culprit.

Was the printer stable before the firmware upgrade? What else has changed and it could be something that seems unrelated. Does it reboot while just sitting or does something have to be moving?

You could unplug everything from the board except the display and see what happens.

I don’t know about the Dreamer, but on my Creator Pro, I had a similar reboot issue that turned out to be a loose ribbon cable going from the motherboard to the LCD/SDCard/Keypad. It was usually triggered by vibration, either during printing or my working on the printer during preheat, etc (like the vibration caused by closing the door on the printer). However, it wasn’t consistent enough to do it every time. When I finally opened the electronics bay to investigate, the first thing I noticed was that the connector on the ribbon cable wasn’t firmly pressed into the connector on the motherboard. After reseating the connector, it stopped rebooting. Hopefully yours will be as easy to resolve.

I’ll look at that, thank you :slight_smile:

Yes, it was stable. The only other thing that started happening, is that it wouldn’t read off the SD card or connect by USB/WiFi, it would say ‘error’ and reboot. Also, I couldn’t update the firmware at that time, until recently. When I plugged it in and fired it up, I tried to update the firmware, and it took it. This was after letting it sit for about a month. USB works now, but I haven’t tried the SD card yet.

Did you ever solve it? I have a similar issue on mine.