Hello i did build a custom 3D Printer. It is running Marlin with the Ramps 1.4. Mechanically it is working fine. I wanted to print a Cube. The printer does only half of the first layer and then restarts the board. I am using Cura as slicer but also tried Slic3r. I tried to printed from an SD Card and directly from Cura with the same result. I got Endstops at (0,0,0). The Internet didn´t gave results but i don´t really have ideas for keywords.

I would really need some help. Thanks.

What do you mean by “and then restarts the board”? What do you mean by “and then stops”? Please try to describe precisely what the printer is doing.

1 Like

Did you try slicing a different object? There could be an issue with the STL preventing from completely slicing. Could be an error in the GCode file throwing off the printer from continuing. Did you at least re-slice the same file to make sure it was not just a poor slice. It could also be your setup of Cura and making sure you selected the right firmware type for your machine as each firmware type has some special commands that could be throwing the printer off if incorrectly setup. A remote possibility is that your power supply is dropping out (but that occurring at the same point on two prints seams a bit remote, but maybe since you only have a sample of 2). There is a grocery list of possible issues if it is a home built and this is the first run. Just need to start with the most common and talk through the evidence.

Also noticed a possible first layer adhesion problem. What kind of plastic are you starting with?

1 Like

If the board is truly restarting, IE, you get the splash screen which would be what you see when you first turn it on, or if you go away and come back to the screen looking like it hasn’t printed (it would say something along the lines of “printer ready” rather than “done” or something like that) Then it could be that your power supply doesn’t have enough wattage. Do try the other suggestions before getting a new supply. It could be a problem with Cura or with that STL.

If you have a multi meter, you can check to make sure that your supply has enough power. Plug everything in to your printer and turn it on. Read the voltage off of the power supply. If the voltage is around 11V or lower, then you have a problem. If it is 12V or higher than you should be good.

Again, try to fix it in Cura first before the power supply, that will save you at least $30 if you’re in the US. Not sure what they cost in Euro.

1 Like

Thanks for the answers. I don´t think the PSU is underpowered. It has 350W and my Bedheater has its own PSU. Any way that the STL is broken could be possible.

I mean by “the Printer stops” that the extruder stays at the last Position and than it restarts and i get the splash screen. It stops at the same position every time with Cura and Slic3r.

I will try to use a new STL and a different object (something Cylindrical).

The reboot is odd. To different slicers would not generate gcode with the same error causing a reboot. You try and reflash the aurduino. Is this firmware you configured, compiled and uploaded to the arduino?

1 Like

That the printer restarts and displays the splash screen makes me think that its microcontroller is crashing. Which might possibly be memory problem, or a bug in the firmware.

If the new STL doesn’t behave any better, try updating or reinstalling the printer firmware.

(Edit: Ninja’d by dmyers7 by two hours. Oh well. :slight_smile:

1 Like

Well i reuploaded Marlin on the Printer. I also used two different CAD Programms to make a cube and a cylinder. With the cube same result. The Cylinder had also the same result. Then i used Pronterface hoping it would give me an error code. Some how Pronterface wanted to move the Printer to 0,0,-19. So it crashed there. I believe now that the Printer restarts every time it has to move up. Allthough it does not make sense because if i move axis, the z axis is correctly defined and moves.

So to my theorie, the printer is at (0,0,0). The print starts. it is laying the first layer. At the half it has to switch sides and wants to move up. It moves up. But somehow the Microswitch is still triggert. -> Error

printersetting2.png printersetting3.png

Sounds like you have a short occurring which resets the system. Turn on the bed and extruder and move the platform around the center point a bunch and see if you can get it to reset. If it does, turn off the bed heater and repeat. If the reset tops the bed wires may be shorting. If still resetting, turn off the printhead and repeat. It may also be stepper related. An chance the downward cooling fan is turning on at that point in each print and that is causing it? There is a terminal g-code command and usually a software interface button to turn the cooling fan on.

1 Like

An Update: I redownloaded Marlin and reuploaded it on my Ramps 1.4 Board. Meanwhile i have still the same problem were it stops at the same position every time unrelated to the geometry nor time. Is it possible that it is a problem of the board not of the software? I bought it of Ebay.

I solved the problem i don´t know what was actually wrong, since cura, slic3r or craftware did not work. I updated Cura and suddently it worked. In the first print i also lowered the speed (30mm/s) but i am now again at 50mm/s and it still works.