The filament does not get chewed up and the and there hasn’t been anything wrong with the temperatures. (I installed my hot end on another printer, and it worked fine) The motor doesn’t seem to have enough strength to push the filament through, it is unable to strip the plastic off the filament. It twitches back and forth when it hits any resistance. The hot end is also completely clear of all plastic debris.


If the same behavior is occurring with different motors, then the issue is likely not the motors. It could be a physical issue with your controller board such as power delivery or firmware. Also, wiring is always a possibility. “Jerky” sounds like a bad connection, so that may be a good place to start.


It is a modified Prusa i3 printer, the whole extruder assembly is completely clean and free of debris. The two wheels are under the correct tension. The plastic does have the small dimples. When the filament does not extrude, it is not being stripped either, the motor simply twitches back and forth, like it’s too weak to do the job.

1 Like

Thanks for the reply, I’ve ordered new wiring. I’m not sure it’s the control board, because every other motor works perfectly, and it’s a new board that I had replaced rather recently.

1 Like

When the motor is not installed, I can easily push the filament through. Even when the motor is installed, if I help push the filament, the motor will extrude it, on its own it is unable to.

1 Like

I now know it’s not the hot end, I’ve installed it on another printer and it worked printed fine. I checked the vref, and it seems to be sitting at 0.2. How much would I have to turn the trim pot on the stepper driver to increase this? Or is that just for increasing the current?

1 Like

My vref is at 0.2, what would be the best way to increase this?

1 Like

Is it a RAMPS board? If so, check to make sure you have all the jumpers in place. Got tripped up by that one more than once. Try swapping out drivers.


The following possible causes come to mind

a) physical connectivity: polarity reversed?

b) firmware needs reflashed

c) hotend temp lying! Thermistor issue? (it it doesn’t extrude, maybe its not hot enough)

Please use the “divide and conquer” technique for troubleshooting

Isolate the faulty / problematic variable. Do this by testing the integrity of each component SEPARATELY. This will include running the stepper motor by itself from a static power source, or plug it into a different port then manually control it to determine if its faulty or healthy. Also, you’ll need to test the port on the controller board with a different motor. When testing it don’t have the motor installed on your extruder. Divide and conquer.

“Twitching” instinctively seems like a physical connectivity issue. A shorting wire that is exposed or something else that is affecting the continuity of the circuit.

EDIT: not enough power to extrude the filament could be just that: a power issue. You need to use a multimeter to check the appropriate power is being delivered all the way from the PSU to the stepper motor’s port.


Can you make a picture of your electronic board (ramp)? So we can check together where the pololus are and I can follw you better in adjusting the value.

We also do need the type of your extruder stepper motor, in order to know the electric features

Feel free to send the picture(s) to


Try upping the current it is receiving.

1 Like

It is NOT the stepper. They rarely fail, and your testing and subsequent posts imply it is not the stepper.

It is likely the wiring has gone bad. This is common for the stepper wires, which break inside from repeated same movement over and over.

Test a different wire, such as using the one from your y-axis. I’ll bet a dollar you will see the wire is bad.

PS If you have a ptfe liner, replace it now and then, it can cause these issues, but my money is still on the stepper wire.


A whole dollar? :wink:

when steppers fail, it’s usually due to overheating which can warp the core where the windings are wrapped. This will cause the rotor to “hunt” for its index. In my case, the stepper would oscillate back and forth.

1 Like

Update (Problem has been located):

  • I switched the cables around, and there was no change.
  • I switched the stepper drivers for the extruder and the z-axis, and the filament started extruding more smoothly than ever before!
  • I had switched the drivers before, but with a different motor for the extruder. With the original motor for the printer, and the z-axis driver, it worked.

Thank you to everyone who helped, hopefully when the new driver gets here, there will be no more issues!

Thanks for the help, but I have actually found where the problem was. It was the stepper driver for the extruder.

It actually was the drivers! I switched them out the first time, using the newer motor I had, and nothing different happened. When I switched to the motor that came with the printer, and then switched the drivers, it started extruding plastic perfectly. Thanks for the help.

Good to hear. Thought you had checked the drivers and they were ok but good it is solved.

I experienced something very similar, mine was harder to track down as it would only occur occasionally during prints. My printer would start out fine, then some time during the print my extruder would start jerking like you described. I thought it was temperature so I added active cooling, which did not help, I finally tracked it down to the plug on the end on the cable where it plugs into the stepper. The way mine is set up the flexing over time wore it out, and instead of trying to order a new one from china, and possibly having the issue again, I opened up the stepper and hard wired the cable, then built in a little strain relief using the case of the stepper itself. That was probably close to a year ago, and have not had an issue since. But in diagnosing this you need to be careful with the steppers being unplugged while being energized.

1 Like

I am having same issues. Filament wont feed. Stepper motor goes forward and back. Here what I have done. Swamped stepper motor cable - Cable was fine. Replaced complete extruder tip and tube - No difference. Changed Stepper motor - No Difference. Adjusted Stepper motor current - No difference Changed gear on feeder - No Difference. Changed guide wheel on extruder - No difference. Tried stepper with no filament in it or tension on the guide wheel - Motor still doing same thing. Reflash controller - No Difference. Replaced controller board - No difference. Reflashed new controller board - no difference .Checked power supply Voltages - All voltages rate where they should be. Scratched my head - no hair left. The only thing left is software. Same thing is happening in Cura and Mattercontrol. Have also reinstalled both. Help I am going crazy with this.

Does the original stepper have this issue plugged in somewhere else?
This still sounds like a cable issue.