I have the same issue as the user above.

When I hit ‘Home All’ it moves to the corner spot at the level that I expect (1-2mm from bed) but then whenever I hit print it lifts up 2/3 inches and starts printing mid air.

I have calibrated everything according to the manual. I am at a loss.

Hello, It sounds to me like either you have an offset configured in your slicer or you set your home offset above the bed at some point. Try doing this: in your LCD menu, go to Prepare. Select Auto Home to perform a homing without computer input, then select Set Home Offsets. What this does is home it, then force that point to be {0,0,0}. If that doesn’t help, you probably have a Z axis set in your slicer. Hope this helped, -Karl

1 Like

I don’t have these options on my LCD menu. Perhaps I’m running an older version?

Ah, I assumed the Duplicator i3 runs Marlin but that may not be the case. Could you tell me what firmware it does run? You could probably search for a more firmware-specific solution.

I had the same problem. The carriage which holds the nozzle was slanted. so it will raise when going to the right. I just had to tighten a bolt at the left motor. So the left rod will spin again. And hold the carriage horizontal.