So I updated to the ADVI3++ firmware now i am having no end of trouble with stringing. I have done 18 retraction tests and they all seem to come out the same no matter what changes i have made in CURA.
Using PLA not that old, .4mm nozzle settings are .2mm, 100% infill
retraction ranges from .5mm to 7mm, retraction speed ranges from 5mm/s to 70mm/s, travel speed 100mm/s to 170mm/s. have readjusted the cooling fan, tried coasting, adjusted accelaration and jerk setting, PID tuned, steps calibrated.
should i just go back to stock firmware? Any advice would be greatly appreciated.

Did you check if your printer is oozing material while idle?
What about the print temperatures?

i am doing some test prints now concentrating on print temps and flow as there is oozing while idle. Thanks.

Alright let me know, now I am curious

Ok so I tried a few different test and no changes until no filament. I sat and watch closely and thought that i didn’t notice anynretractions at all, so I sliced with slic3r minimal editing and perfect so i uninstalled cura and reinstalled and started feom scratch used the settings i used in slic3r and no change.
Looks like i am going to use slic3r from now on.
left pic cura 3.6.0, middle slic3r, right reinstalled cura 3.6.0.

really strange!

When slicing from my laptop no issues but when slicing from my desktop I got under extrusion.
It just makes no sense!
But you say that the settings with Slic3r and cura and identical?

probably not identical as i am not familiar with slic3r but as close as i could get. Only have a laptop so cant try on anything else.
Cura just wasnt retracting for some reason.

hmm, I still am running on Cura 3.2 or something, but my pc has 3.6 as well, so maybe the fault is in 3.6. When I get home from work; i’ll search for the cura I am using on my laptop since that works like a charm maybe you can try that.
If that works we can submit a bug to ultimaker