Hi! I have had my Wanhao duplicator i3 plus now for about 6 months. It has had only one modification, that being a much larger MOSFET put in place, which is now driven by the much smaller, original MOSFET.

That was about five months back. The machine has worked great, and prints very nicely. But a few days back I started noticing that it was taking longer and longer for the bed heater to begin working. Sometimes it would not start heating at all. I tried shutting the printer off, unplugging it for a few seconds and then restarting the preheat cycle, and that worked once or twice. But this morning the bed heater has refused to work at all. I opened the machine and checked all connections, they were all clean and tight. The soldered connections to the bed heating pad also were clean and tight. No cooked wires anywhere. The temperature sensor still works fine. The extruder heats fine as well. If I use the debug and set the bed temp to 0 deg C, then the printer will begin to print. But if I set the preheater and then select a file to print, the bed temp hovers between 20-21C while the extruder heats up to 215C, but then the printer just sits like that forever, and will not begin printing. Any ideas?

It is not printing because the print s/w is waiting for the bed to heat up. Troubleshoot the voltages on the FETs to determine where the problem is. Obviously, the heater is not receiving power.