Hey all,

I got myself a secondhand Leapfrog Creatr HS for not that much. However, It is stuck in a boot-loop. The screen says “Starting up … Screen will go black for 1 minute.” together with the Leapfrog logo.

My plan is to flash new firmware onto my Creatr HS and I tried to do so by following the steps in the guide on this page http://support.lpfrg.com/support/solutions/articles/1000084097-uploading-the-creatr-firmware-

Everything went well up until the point where I had to select the COM port. No COM port is showing up whatsoever. I tried this step with the printer on and with the printer off and got the same result: nothing.

Could someone help me with this issue? Or is there any other way to flash firmware without the ability to use the screen and button.


You may need a driver on your computer in order for it to actually talk to the printer at all, that’s why I think the COM port isn’t displaying - the computer doesn’t recognize that the printer is there

Thanks for your reply! I managed to fix my issue by reinstalling the software on the internal SD card of the Lepfrog Creatr HS printer!