Was reading people saying that if your 3D printer is more than a year or so old, you should update the firmware. I fell for this lie, and upgraded to newer stuff. Took about a week to get everything working right, except for this: On both the hotend and the print bed, if I set a temperature, it starts heating, and the temp on the display rises. And while the display is telling me the hotend is at 240ºC, the actual temperature it has reached is about 165ºC. Bed does the same, set for 100ºC, and only get about 65ºC. In both cases it is about 65% of what it is supposed to be. I have adjusted PID, I have tried different thermistor tables, even tried making up my own thermistor table, it still does the same thing. If I connect the heater cartridge to 12 volts, it will quickly heat the hotend up to a actual temp of 240ºC, but then the display is telling me it is like 350ºC, which it is not. I feel sure I am missing something simple and stupid, but I have been working on this for a month, now, to no avail. Any ideas or suggustions will be greatly appreciated.

What firmware are you running?

You’ll need to make sure that the temperature sensor information in the firmware matches the hardware you’re working with, or else the numbers will be incorrect as you’re seeing.

What printer are you using, and have you changed the hotend at all?

Sorry, thought I had mentioned I was using Marlin, in a Chinese i3 clone. I have tried the latest version, and I have tried older versions. Same problem. I did change the hotend, when I discovered the problem, switched back to the old thermistor and heater block. Same problem. I have tried ALL the different thermistor tables in Marlin, and even tried making my own thermistor table. Same problem. I did NOT change anything on the bed, and it shows the same problem, I am only getting about 65% of the temperature it has been set for. The display says it has reached the set temperature, but in reality the temp is only 65% of what it says. I have gone through everything in Marlin that has anything to do with temperature (that I can find) and still no difference. What stumps me is that the machine says it is getting to the set temp, and controls the temp at that spot just fine. It just never gets hot enough to actually melt plastic. I can turn up the set temp to where the actual temp is almost hot enough to work, but something always cuts it off and says there is a temp fault. So, I am looking for any ideas on what else I can try. Thanks for your response.