Hi, So I am running a rostock style 3d printer from Geeetech with stepper motors and belts. It would appear the one of my motors has died and I don’t know why. I have been looking online for troubleshooting options but have had trouble finding anything for exactly what I have. Just wondering if anyone has any tips.

The motor is a 1.8 degree motor and when it is hooked up it simply doesn’t respond to any commands. I took it off the printer and it felt stiff or maybe jammed, so I did the logical thing… I took it apart. Nothing on the inside appeared to be wrong or amiss but I have never seen the inside of a working motor so I don’t really have a basis. I put it back together and it seams to no longer be jammed or stiff but it still isn’t responding to any commands.

I am assuming there is something wrong so that it is no longer receiving a signal since it works based on pulses of voltage and a magnet unless there was no voltage or it was jammed there doesn’t seem to be any other reason it wouldn’t be working. So I checked and reuploaded my code that the arduino is running on and still no response. I think either my motor or my cable is dead.

Any tips or insight are very very welcome. Thanks guys!

Hi clay, Stepper motors dying aren’t unheard of, but in my experience it’s much less common than simply blown stepper drivers. Have you checked the stepper driver for that motor? Try to swap the motors’ plugs. If a working motor doesn’t work on the non-working one’s plug then it’s likely a blown driver or (hopefully not) a damaged axis on the control board itself. If the non working motor still doesn’t work, then if may be that the motor itself is actually damaged. However, stepper motors aren’t actually complicated. You could try to take it apart and verify and maybe fix all electrical connections, as well as clear all blockages, before resigning yourself to buying a new stepper. -Karl Zhao

1 Like

Hi, Thanks for the tip!

So I took off the Y motor and plugged the not working x motor into the why chord and the motor worked. So it isn’t the motor that is broken. I then switched the wires to check if it was simply a short in the wire. The other wire worked in the y spot as well. So i’ve determined that something is wrong with the motherboard or just the port. I am contacting the company from which I got the motor and going to see what they recommend. Do you have any other tips? you’ve been very helpful.

-Clay Hall

Assuming you have interchangeable stepper drivers, I’d start with trying to swap or replace the stepper driver for the non working motor first. It could be just that the driver is blown, which would be easily solved with a new driver.

What would a new stepper driver look like? All I can see on my set up is a plug going to a cable from the stepper to another plug on the arduino