Hi all, I have already printed several fairphone cases, recently i had to print the Grippy Fairphone case. I did it twice because i tried some different settings.

When the two cases were compared i saw that some artifacts were shown at the same places. Before comparing i thought they were due to some oozing or problems with the printing. But the fact that the same artifacts come on two different prints made me think.

So i took a look in the layer view in Cura and i have something similar to this:

Case Day1 top hole.jpg

(It’s a screenshot from another case i found on talk).

You see the small lines that are added? That’s the problem.

NetFabb or MeshMixer detect some errors but when i repair it the case gets worse.

Anybody knows how to resolve this? Joris maybe?

The artifacts can be cleaned but it would be better not to have them


One more thing to add: This problem probably occurs on most of the cases i already printed as i noticed some artifacts that i couldn’t explain so this might be a general issue on the STLs…

I had issues like that with some versions of slicer so it might as well be an issue in Cura.

If you post the file I can have a look at it. Automatic repair in most mesh tools sometimes lead to worse problems.

Hi Didier,

This is not something I recognise. Do you maybe have a picture of the artefact on the printed case it self so I can compare it with my own case and others we have printed here at the Fairphone office.

No sorry the case has been sent and i only have pics of it cleaned.

What i can do is take some screenshots of the slicer (i used Cura 15.01 if i remember well). And do a test print of a faulty part so you can see.

If you put the STL in netfabb it will show errors (meshmixer also), some kind of holes.

I’ll come back to you with clearer pics as soon as possible

Ahh, I do not really have experience with Cura and such. I don’t do the printing here, I just do the support.

yes correct, same problem on my side wit halmost all cases. This issue has already been discussed in 2014, but it seems that there is no official solution.

I also tried different Cura versions without success…

I made a picture of my own case which was printed here at the office. Do you mean the patterns on top of the case that you can see here?

No, i added two pics of my latest Grippy Case, it was cleaned as much as i could but still shows some artifacts, i highlighted them in red.

I can assure you that they are printed and that it’s not a problem with the printer but more with slicing of the STL in Cura. As i said the layerview in Cura shows some added lines there (i will provide a screenshot when i’m home).

So it’s more of a Cura issue with the STLs (although netfabb and meshmixer detect errors). Cura must be doing some kind of automatic repairs that cause this kind of weird behaviour.

Maybe a combination of the Fix Horribles options could solve this (or make it better).

Thanks for those pictures. This really helps.

I am going to discuss it with my colleague who can work on the designs.

Try opening the STL in NettFabb or MeshMixer it will show the errors.

Or slice it with Cura and go to layerview to see the extra lines that create the artifacts

“Maybe a combination of the Fix Horribles options could solve this (or make it better).”

Nope, tried it directly after I read your message -> no success :frowning:

btw: the ‘grippy’ case seems to be the worst of all.

I don’t think that this is a Cura related issue, because Meshmixer and Netfabb are telling me that the mesh has several defects. Unfornately both are not able to repair it properly…

That’s what i thought too… I tried several of them but not all the combinations… but if netfabb is showing errors then yes any slicer should fail (or is it Cura that is correcting some errors automatically). I have to check in Simpify3D if it shows anything

Hi Didier,

any news about that issue?

Nope i didn’t take the time to test anything more about this sorry