After about 10 to 20 seconds i think it just stops suddenly. I must say that there are models which it keeps printing until the end but some complex models just stop. I use the cura i got with the sd card. Maybe there is some problem with the g code idk please help

1 Like

How are you printing? Are you saving the gcode directly from Cura to the SD card? If so,

the card has probably become corrupted. You should save to disk, then copy to the

card as it has a very small, and primitive file system.

If you are printing from your computer via USB, then your computer could be the

problem, if it goes into sleep mode or something.

Hey thank you so much for your kind response. I will tell you exactly what i do. And there is another problem. First i use sd card. (The one i got with the printer) but before it i must mention that i tried to do the same model yesterday and it worked perfectly. It started only today. Every model i put in the card. As i try to print it. It just stops after about 15 secs and does nothing. The interesting is that right after i put the model into the card when i review it in cura it shows me the whole model sliced (am not sure if that is the right word) but it display the entire work but after i try printing and as it stops after about 15 secs i take the card put it in the computer open the same file i opened before (that showed the whole model) and now it shows exactly the actual print it just did on the printer. Like the rest was removed. And all i see is the first 15 secs or so of the print. What can i do. Thank you so much for your help.

Sounds like the file system on the SD card is corrupted. You can reformat it as a FAT16 file system with your computer. Don’t save gcode files directly to the SD card. Save to your local disk, then copy to the card. Also, don’t keep too many files on the card or use really long file names.

that’s a good idea and it seems to really be corrupted. my other problem is that the printer doesnt read any other card except this one. tried 4 gb card i got and it says the micro sd card is empty what can i do i even tried more than one format fat 32 and fat. and just to point out you can see 4gb is not high capacity card so it shouldnty have a problem of max capacity issues. but to be honest today i tried another card which was on my phone. 2 gb card and it worked. i tried to print with it and see if i have the same problem with the first card and it worked it printed very fine. but still i am not sure i can live with a printer which can only use up to 2gb sd cards that is really limiting and really unsufficient in my opinion besides if my friend gave me his card to print some of his models i wont be able to other if i transfer it to the 2 gb card which start to get complicated. what should i do maybe you still have any advise? or should i send it back to get replacement. what do you think? thanks a lot man really

It’s the formatting of the card. Fat32 won’t work. Fat or Fat16 should.

If you have a card that is good, then import the card image and write it to your card.

import the card image? what do you mean? btw i just watched a video about upgrading firmware which made me think maybe its all a firmware issue? maybe i need to upgrade it what do you think? btw i tried formatting the card to fat as well as fat 32 both didnt work and it was 4 gb card i can try again with another card would love to hear what you think. thanks

What is the version of Cura you are printing with it? Find this out and if possible, get the latest version which comes with a lot of extra features to support your printing jobs.

Can you please tell me what kind of features? Before i do it. I use the cura i got with the sd card came with the printer. And to point out. I heard that another version of cura beside the one i got with the printer might have issues. And last thing. Can you try saying what you think about my micro sd card problem which i cant use any with bigger capacity than 2gb


I also own a monoprice select mini and am currently having the same issues as you. About the micro SD card this printer will only accept sd cards and not sdhc or sdxc (should be stated if you buy one). Micro sd cards are rarely available now (as they only come in 1 or 2 gb) but I was lucky and managed to find 2gb at an electronics store. I am trying deleting the extra files on the sd card and reformatting the disk to Fat and will inform you if it works. Lastly I recommend using Cura 15.04.6, that may be another issue if you are using a different version.