Greeting everyone,
I just finished installing the mosfet for the heating bed and now I cant get the screen to show any characters. It turns on, but its just the blue background. The controls are still working but i’m flying blind in terms of trying to do anything with it. I did get it to home out the print head but that was it.
It did work fine before the install, and I did remove the ribbon cable but it all seems like its intact still…

I think there might be a potentiometer on the back of the LCD that adjusts contrast, have you tried tuning that?

1 Like

Would that be the tiny screw in the green lit up circle? If so no I haven’t touched it but would be willing to try.

It looks like that would be it - make sure whatever instrument you use doesn’t slip and tough the board, or alternatively have the machine turned off before adjusting, then turn it back on to test, etc.

Well, I tried adjusting it to no effect. Same problem.
Now the question is how do I run the printer directly from my laptop? Is it as easy as plugging a USB in or do I have to find some program for the laptop to make it work?
Thank you

Yup you can generally plug in the USB to your computer, and then to the board of the machine. Slicers like S3D and Cura will let you send the code directly instead of saving it to an SD card as usual.

If you go this route, make sure you have automatic updates off/ turn on “metered connection” for your WiFi if you’re using Windows 10, so an update doesn’t interrupt a print.