So I have a small fleet of 3D printers at my workplace, most of which are Makerbots. They vary in age and in model (Replicator 5th Gen, Replicator+ Replicator Z18). I have tried to update the firmware, but some of them are old enough that they are stuck on a previous version.

I keep getting Error 57: Heater Temperature Sag Triggered (photo attached), and the Makerbot support page isn’t particularly helpful.

I have tried replacing the extruders with new ones, taking apart and cleaning the extruders, using extruders on different machines, using Makerbot Print and Makerbot Desktop, and I have still run into this error on every single printer. Sometimes it happens once in a print, and sometimes its seven or eight times in the span of half an hour of printing. In general, the prints produced until the error appear to be just fine, save for an occasional small blob of filament.

Any advice on how to fix this error or at least minimise it? I would really appreciate some help.

Hi Emily,

Are they in an open area? place them side to side in a closed small room and keep the ambient temp around 25C or higher. Are you printing above 215C degrees? how about power distribution, how are they connected?


They’re in a fairly small room connected to several different outlets around it. I tried increasing the temperature and arranging them as you suggested, and I’ve had significantly fewer instances of this error since then. However, it does still happen. I typicaly keep my printers set at 215C.

1 Like

Do you see any slight changes in brightness of the white LED below the gantry while the extruder is heating up? if so that means the extruder is taking too much current to heat up, maybe the power supply is not providing enough power or the heating element/circuit is bad, that can be for a lot of reasons to get error 57. The printer is trying to keep the temp in range but it doesn’t work. Questions, do you have the air guide brackets on your extruders? have you tried printing with the filament cooling fan off? did you try lowering the printing speed?

1 Like

Hey guys,

I think I can finally offer a solution to this issue.

The cause:

  1. There might be a faulty heater
  2. There might be a faulty temperature probe
  3. Temp is set too high beyond the extruders capabilities
  4. Fan speed exceeds manufacturers specification
  5. Temperature bleed into the zone cooler

While causes 1-2 are very unlikely they cannot be ruled out entirely. The fix is to remove the yellow tape on the underside of the extruder head and release the two ellen-key set screews.

Pull out the probe and heater and replace them. (you’ll need to cut and mend cables).

Causes 3-4 are due to your settings. The MB5gen is best for PLA and reallly is not made for temps of 230+. Also if your 3d party printing software allows fan speeds of more than 100% think carefully.

So on to cause #5
Dismantle your extruder (best is the smart extruder plus).
Dismantle it so far as that you have access to the cooler ribs. Then carefully loosen the black plastic part hooked into the top-most rib and remove it.
With a proper sized wrench or carefully apply torque to the cooler rib assembly, it’ll remove out of the extruder head assembly, giving way to only the extruder head, the nozzle and the 4 wires going into the extruder head.
Remove the yellow tape and all the gunck and stuff that might have accumulated there. Clean the surfaces with some sand paper.
Then reassemble everything and place some mineral wool (or something that thermally insulates and withstands the temperatures in that area). Mineral wool is ideal.

I just did that fix and it’s working like a charm.