I almost finished calibrating the printer as well but when I try to print something through repeater host and through the normal procedure the printer starts moving up and down then stops and the program says it getting heated up (the extruder hotend) and after its done heating up and gets to about 200 degrees it goes up fast and when it went up to the most top position it starts shaking really bad and does nothing else so I have to stop it before the screws of the printer starting falling off. anyone have any idea what should I do? I uploaded the firmware through Arduino and all set up. did exactly as the instructions said but still this problem it just shakes so bad and nothing happen so I emergency stop it.

thanks ahead

Man, I don’t know but I found my geeetech to be very temperamental and bought a Printrbot instead. My Printrbot simple works like a dream.

what do you mean? so I just should throw it away? I paid for this and spent a lot of time building it I hope that not the only solution

Do the following steps in sequence

- Check twice if the motors are connected in the right spots in the motherboard
- Check if the motors are connected at all
- Check if the current of the motors isn’t to small
- Check if the bouldrate is right
- Try printing via SD Card
- Try other slicing software, repetier host is pretty bad in my opinion, may be causing some trouble.

Didn’t mean to dishearten you. I was just referring to my experience. Do you have any 3D printing suppliers in your area that sale Geetech? You might take it to one of them to check it over and make sure you have everything together and connected correctly.

just for you to know. when I use the program for instance to click on the print panel ALL HOME (means for all the motors to get in the homes position) it works well. all the motors and the rods work almost seamlessly so the motors not connected well is not the problem. or I am wrong? and it still can be? would love to hear your opinion. another thing. can you please tell me how to use sd card? how do I move the sol file into the sd card so it will read it properly? and if I should put the G code then how do I do it? and link for a simple guide would be enough. thank you so much for trying to help and one last thing maybe the problem is that I didn’t insert the filament right? or any thing that could be beginners problem?

Well, the filament is not the problem, since all motors are moving, I really recommend changing the software. Download Cura, it’s a free and much better slicer than repetier host. Download link: https://ultimaker.com/en/products/ultimaker-cura-software

Download and install it, then put your model in there, don’t do any configs, just keep it in the recommended settings. Plug the SD Card in your computer, then click in the bottom right on the “save to SD Card”. If it doesn’t work just check if the unity (C: D: E: etc.) is right. After that, the program will save the .gcode file in the sd card. Eject the card safetly with the windows ejecting system, or just click on the eject button that will show up after you save the file in the program. Plug the SD Card in the printer, the slot is usually in the back of the LCD Panel, or in the motherboard. Plug there, navigate in the printer menu and start printing the file. See if it works, this should solve the problem.

If you have any doubt, you can find tutorials in the download page, just scroll down a bit.

I tried what you said and surprisingly the printer works with sd card and I tried now from another computer (windows) in relation to Mac and it works through usb as well. what in the world. but now I have another problem the filament doesn’t leave the hotted head its maybe getting accumulated there a bit by bit but it doesn’t go out freely as its supposed to the printer moves as it seems to be printing but nothing comes out. thanks a lot for you guys for trying to help and you did I think. waiting for response.