Last night was the first time I ever tried to use the SD Port on my printer, I tried 2 SD cards which are working and I had copied the G Code onto

After inserting both of the SD Cards, the LCD stated “NO SD Card Inserted” yet I could read both cards on my laptop.

Can anyone help me out with ideas???

Hi, You have to restart the printer after you inserted the sd card. I have the same problem but after a restart the printer can read my sd card. Regards, Joeri.

You will need to make sure the cards are within the specs of what the printer firmware can read. Some can’t be bigger than 2gig, no folders, short file names and no special characters.

If you need to format the cards then google SD card formatter. There is a good one you can download.

thank you, I will purchase a smaller card and try

thank you, once I purchase a smaller card I will if it doesnt work still, I will try to restart the printer

What size is youre sd card? Mine is 8 gb.

Mine is also 8gigs

And did you try the restart? Mine sd card is from china (white label) so i guess it will work whit all types of cards.

The sd card is formatted FAT32

Yes the card formatted to Fat32, I again tried insert the card with no reading, then leaving the card inserted turning off and on the printer, the LCD screen then went to 3 lines of blocks across the whole screen, once I removed the card the LCD screen return to normal??

Did you assemble this printer or did it come pre-assembled?

I would contact the manufacturer either way. May be a bad board or controller where the card reader attaches.

I would also go ever all connections to verify they are correct and tight.

See if there is an option on the printer to either enable or disable the SD card reader.

Just some guesses at this point but looking like a bad part.

The Printer came as a Kit which I had to fully assembled

But the issue has now been resolved thanks to this page, I went out and bought a brand new SD Card which I down sized as suggested, then I reformatted the new card to make sure it was formatted in Fat32, then I copied the file into the root directory

… Now working and reading the SD Card

Thanks everyone who helped