Hi, I own a Flashforge Guider 2 and I am facing boot issues since a couple of days.
When I turn on, the printer hangs up at the Flashforge 3D printer screen. Nothing seems to move forward for a few hours after which I turn off.
I have tried resetting using MD5 reset update but to no effect.
Any one facing similar issues?

Yes. You will want to try and get the firmware files from Flashforge and try to flash via a USB stick.
I had it where it would not boot from several USB sticks until I tried one that had never been in the printer at all and a miracle it worked and reflashed.
Their firmware update methods for via Flashprint or WIFI are very problematic and have crashed mine twice. Once I had to buy a new board since it was out of warranty even though the problem was from their update method.

1 Like

Thank you for your response.
I ll try using a brand new USB stick.

not working :frowning: tried using a different usb stick that wasnt used on the printer before.
can you send me the files you tried reseting with?

I use a USB stick that was new, never used and it finally booted from it after several failed attempts with other ones.

didnt work. Local provider is sending a new board until one arrives from the company.

You got lucky. Flashforge told me too bad and would not warranty even though their update routine “bricked” it.
$400 for a new board.